summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrés Rodríguez2015-06-18 00:06:59 -0300
committerAndrés Rodríguez2015-06-18 00:06:59 -0300
commit1bdc859b55fc1c674c1ac5e28e20c3777285067b (patch)
treef7b0b0f09d2cb091919b5de5ccb01c056f4b5440
downloadaur-1bdc859b55fc1c674c1ac5e28e20c3777285067b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cdb258179bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cython2-kivy
+ pkgdesc = C-Extensions for Python; Kivy-compatible version
+ pkgver = 0.22
+ pkgrel = 1
+ url = http://www.cython.org
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = python2-setuptools
+ depends = python2
+ provides = cython2=0.21.2
+ conflicts = cython2
+ source = http://cython.org/release/Cython-0.22.tar.gz
+ md5sums = 1ae25add4ef7b63ee9b4af697300d6b6
+
+pkgname = cython2-kivy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b971aad2447
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Andrés Rodríguez <andres.rodriguez __at__ lithersoft.com>
+
+pkgname=('cython2-kivy')
+pkgver=0.22
+pkgrel=1
+pkgdesc="C-Extensions for Python; Kivy-compatible version"
+arch=(i686 x86_64)
+url="http://www.cython.org"
+license=('APACHE')
+depends=('python2')
+makedepends=('python2-setuptools')
+provides=('cython2=0.21.2')
+conflicts=('cython2')
+source=("http://cython.org/release/Cython-$pkgver.tar.gz")
+md5sums=('1ae25add4ef7b63ee9b4af697300d6b6')
+
+package() {
+ cd $srcdir/Cython-$pkgver
+ python2 setup.py install --root=$pkgdir
+
+ mv $pkgdir/usr/bin/cygdb $pkgdir/usr/bin/cygdb2
+ mv $pkgdir/usr/bin/cython $pkgdir/usr/bin/cython2
+ mv $pkgdir/usr/bin/cythonize $pkgdir/usr/bin/cythonize2
+}