summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2022-03-03 12:34:48 -0500
committerGuillaume Horel2022-03-03 12:34:48 -0500
commit26e370ff71a48901d0104b2f8ed3a407a8779125 (patch)
tree872e26755f663277335651bc6d59490dcaf38691
parent950d17b9f52cb4a8b47cc8d9eaf01730c6f902fb (diff)
downloadaur-26e370ff71a48901d0104b2f8ed3a407a8779125.tar.gz
bugfix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d13bf9dd6c8d..606d00820280 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cython3
pkgdesc = C-Extensions for Python
pkgver = 3.0.0a10
- pkgrel = 1
+ pkgrel = 2
url = https://cython.org
arch = x86_64
license = APACHE
@@ -11,7 +11,9 @@ pkgbase = cython3
conflicts = cython
source = cython3-3.0.0a10.tar.gz::https://github.com/cython/cython/archive/3.0.0a10.tar.gz
source = cython-hash-int-conversion.patch::https://github.com/cython/cython/commit/28251032.patch
+ source = https://patch-diff.githubusercontent.com/raw/cython/cython/pull/4528.patch
sha256sums = d530216e015fd365bf3327a176e0073d0e5b8d48781f387336459f10032d776f
sha256sums = 28b2b065a9853e86d0bc09287e8a21f50ebc1f3cfee3b2ab03b6b917cb9e81d8
+ sha256sums = 54a6c1fa1830fdcd3aac596877622bdf25e928d7a2947a001325d12e0a4dc219
pkgname = cython3
diff --git a/PKGBUILD b/PKGBUILD
index 21e21e9b3c85..0eb6f85b55d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=cython3
pkgver=3.0.0a10
-pkgrel=1
+pkgrel=2
pkgdesc="C-Extensions for Python"
arch=(x86_64)
url="https://cython.org"
@@ -14,9 +14,16 @@ makedepends=(python-setuptools)
provides=('cython')
conflicts=('cython')
source=($pkgname-$pkgver.tar.gz::"https://github.com/cython/cython/archive/$pkgver.tar.gz"
- cython-hash-int-conversion.patch::"https://github.com/cython/cython/commit/28251032.patch")
+ cython-hash-int-conversion.patch::"https://github.com/cython/cython/commit/28251032.patch"
+ "https://patch-diff.githubusercontent.com/raw/cython/cython/pull/4528.patch")
sha256sums=('d530216e015fd365bf3327a176e0073d0e5b8d48781f387336459f10032d776f'
- '28b2b065a9853e86d0bc09287e8a21f50ebc1f3cfee3b2ab03b6b917cb9e81d8')
+ '28b2b065a9853e86d0bc09287e8a21f50ebc1f3cfee3b2ab03b6b917cb9e81d8'
+ '54a6c1fa1830fdcd3aac596877622bdf25e928d7a2947a001325d12e0a4dc219')
+
+prepare() {
+ cd "cython-$pkgver"
+ patch -p1 -i ../4528.patch
+}
build() {
cd "cython-$pkgver"