summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212024-03-27 10:14:38 +0100
committera8212024-03-27 10:14:38 +0100
commit44238901a4e835ce54a067cdec93ba6ec2375468 (patch)
tree994867f9349c93df851d5bb45a8f98f99b94d577
parent73a7012ff3f244801fde5d8e5a772c8621ccae34 (diff)
downloadaur-cytoscape.tar.gz
Version 3.10.2
* Update license * Create patches instead of sed(1) magic for easier maintenance
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--0001-fix-cytoscape.vmoptions-file-location.patch41
-rw-r--r--0002-fix-karaf-instances-dir.patch59
-rw-r--r--PKGBUILD20
5 files changed, 121 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8df42f87c409..a461ec0ed478 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = cytoscape
pkgdesc = Network Data Integration, Analysis, and Visualization in a Box
- pkgver = 3.10.1
+ pkgver = 3.10.2
pkgrel = 1
url = https://www.cytoscape.org
arch = any
- license = LGPL
+ license = LGPL-2.1-only
depends = java-runtime=17
depends = bash
optdepends = opencl-driver: for OpenCL support
- source = https://github.com/cytoscape/cytoscape/releases/download/3.10.1/cytoscape-unix-3.10.1.tar.gz
+ source = https://github.com/cytoscape/cytoscape/releases/download/3.10.2/cytoscape-unix-3.10.2.tar.gz
source = cytoscape.desktop
source = cytoscape.png
source = cytoscape
- sha256sums = 7eac40b27a4c602623d215b6a31bbf347e0fa9eb119563ece5e0d27928f2d5a5
+ source = 0001-fix-cytoscape.vmoptions-file-location.patch
+ source = 0002-fix-karaf-instances-dir.patch
+ sha256sums = 02b4fe83719bb52c6adc5bd18b51f8cff929b267050a62a1cc4248e1b08ae381
sha256sums = f4476545086f845e1cec5861169270da9f82a6ad4944972010827a567af0c7d0
sha256sums = 135faa3f0beb8ecc1b704cf376408e8bd5f62f32ba50a84002c14321d0bb0b68
sha256sums = daf81142f560db93aeeea96ca185a2662dd0ec9ee220aee167bf826fc44f3dc3
+ sha256sums = fadbacc92c147dead6f09577aedda08aca3a70c04386d91cbee2562739c5645b
+ sha256sums = 4a65e776ab9092e5828b3c9299add0452b131e1665343bd10758399f67479f47
pkgname = cytoscape
diff --git a/.gitignore b/.gitignore
index 1a09a3d9a151..22d2024b14f8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!/cytoscape
!/cytoscape.png
!/cytoscape.desktop
+!/*.patch
diff --git a/0001-fix-cytoscape.vmoptions-file-location.patch b/0001-fix-cytoscape.vmoptions-file-location.patch
new file mode 100644
index 000000000000..535646c82da6
--- /dev/null
+++ b/0001-fix-cytoscape.vmoptions-file-location.patch
@@ -0,0 +1,41 @@
+From 78c55ffd7640432e2cdf4da40b1eb4b6338ba39c Mon Sep 17 00:00:00 2001
+From: a821 <a821@nospam.mail.de>
+Date: Wed, 27 Mar 2024 09:44:40 +0100
+Subject: [PATCH 1/2] fix cytoscape.vmoptions file location
+
+cytoscape tries to write this file in a write protected directory.
+therefore move this file inside $HOME/CytoscapeConfiguration
+---
+ cytoscape.sh | 2 +-
+ gen_vmoptions.sh | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/cytoscape.sh b/cytoscape.sh
+index 1d3d196..ae3ce0c 100755
+--- a/cytoscape.sh
++++ b/cytoscape.sh
+@@ -58,7 +58,7 @@ else
+ fi
+
+ #vm_options_path=$HOME/.cytoscape
+-vm_options_path=$script_path
++vm_options_path="${HOME}/CytoscapeConfiguration"
+
+ # Attempt to generate Cytoscape.vmoptions if it doesn't exist!
+ if [ ! -e "$vm_options_path/Cytoscape.vmoptions" -a -x "$script_path/gen_vmoptions.sh" ]; then
+diff --git a/gen_vmoptions.sh b/gen_vmoptions.sh
+index b9b0934..3ae36ab 100755
+--- a/gen_vmoptions.sh
++++ b/gen_vmoptions.sh
+@@ -4,7 +4,7 @@
+ script_path="$(dirname -- $0)"
+
+ #vm_options_path="$HOME/.cytoscape"
+-vm_options_path=$script_path
++vm_options_path="${HOME}/CytoscapeConfiguration"
+
+ if [ ! -e $vm_options_path ]; then
+ /bin/mkdir $vm_options_path
+--
+2.44.0
+
diff --git a/0002-fix-karaf-instances-dir.patch b/0002-fix-karaf-instances-dir.patch
new file mode 100644
index 000000000000..acb68ee8e879
--- /dev/null
+++ b/0002-fix-karaf-instances-dir.patch
@@ -0,0 +1,59 @@
+From f87819db35cdc3c8c41b5745aed0dabdd6dbc791 Mon Sep 17 00:00:00 2001
+From: a821 <a821@nospam.mail.de>
+Date: Wed, 27 Mar 2024 09:49:59 +0100
+Subject: [PATCH 2/2] fix karaf instances dir
+
+cytoscape tries to write instance data in a write protected directory.
+create a directory $KARAF_INSTANCES inside cytoscape configuration
+dir for that.
+---
+ framework/bin/karaf | 11 ++++++-----
+ 1 file changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/framework/bin/karaf b/framework/bin/karaf
+index 6b573e4..3dc19cd 100755
+--- a/framework/bin/karaf
++++ b/framework/bin/karaf
+@@ -60,6 +60,7 @@ REALNAME=`realpath "$0"`
+ DIRNAME=`dirname "${REALNAME}"`
+ PROGNAME=`basename "${REALNAME}"`
+ LOCAL_CLASSPATH=$CLASSPATH
++KARAF_INSTANCES="${HOME}/CytoscapeConfiguration/instances"
+
+ #
+ # Load common functions
+@@ -108,10 +109,10 @@ setupClassPath() {
+
+ checkRootInstance() {
+ ROOT_INSTANCE_RUNNING=false
+- if [ -f "${KARAF_HOME}/instances/instance.properties" ];
++ if [ -f "${KARAF_INSTANCES}/instance.properties" ];
+ then
+- ROOT_INSTANCE_PID=`sed -n -e '/item.0.pid/ s/.*\= *//p' "${KARAF_HOME}/instances/instance.properties"`
+- ROOT_INSTANCE_NAME=`sed -n -e '/item.0.name/ s/.*\= *//p' "${KARAF_HOME}/instances/instance.properties"`
++ ROOT_INSTANCE_PID=`sed -n -e '/item.0.pid/ s/.*\= *//p' "${KARAF_INSTANCES}/instance.properties"`
++ ROOT_INSTANCE_NAME=`sed -n -e '/item.0.name/ s/.*\= *//p' "${KARAF_INSTANCES}/instance.properties"`
+ if [ "${ROOT_INSTANCE_PID}" -ne "0" ]; then
+ if ps -p "${ROOT_INSTANCE_PID}" > /dev/null
+ then
+@@ -324,7 +325,7 @@ run() {
+ --add-exports=jdk.naming.rmi/com.sun.jndi.url.rmi=ALL-UNNAMED \
+ --add-exports=java.rmi/sun.rmi.registry=ALL-UNNAMED \
+ --add-exports=java.security.sasl/com.sun.security.sasl=ALL-UNNAMED \
+- -Dkaraf.instances="${KARAF_HOME}/instances" \
++ -Dkaraf.instances="${KARAF_INSTANCES}" \
+ -Dkaraf.home="${KARAF_HOME}" \
+ -Dkaraf.base="${KARAF_BASE}" \
+ -Dkaraf.data="${KARAF_DATA}" \
+@@ -342,7 +343,7 @@ run() {
+ ${KARAF_EXEC} "${JAVA}" ${JAVA_OPTS} \
+ -Djava.endorsed.dirs="${JAVA_ENDORSED_DIRS}" \
+ -Djava.ext.dirs="${JAVA_EXT_DIRS}" \
+- -Dkaraf.instances="${KARAF_HOME}/instances" \
++ -Dkaraf.instances="${KARAF_INSTANCES}" \
+ -Dkaraf.home="${KARAF_HOME}" \
+ -Dkaraf.base="${KARAF_BASE}" \
+ -Dkaraf.data="${KARAF_DATA}" \
+--
+2.44.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 7c1149ebe238..bf7b7d5cbce9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,33 @@
# Contributor: florianbw <florian.bw gmail.com>
pkgname=cytoscape
-pkgver=3.10.1
+pkgver=3.10.2
pkgrel=1
pkgdesc="Network Data Integration, Analysis, and Visualization in a Box"
arch=('any')
url=https://www.cytoscape.org
-license=('LGPL')
+license=('LGPL-2.1-only')
depends=('java-runtime=17' 'bash')
optdepends=('opencl-driver: for OpenCL support')
source=("https://github.com/cytoscape/cytoscape/releases/download/${pkgver}/cytoscape-unix-${pkgver}.tar.gz"
"${pkgname}.desktop"
"${pkgname}.png"
- "${pkgname}")
+ "${pkgname}"
+ "0001-fix-cytoscape.vmoptions-file-location.patch"
+ "0002-fix-karaf-instances-dir.patch"
+)
-sha256sums=('7eac40b27a4c602623d215b6a31bbf347e0fa9eb119563ece5e0d27928f2d5a5'
+sha256sums=('02b4fe83719bb52c6adc5bd18b51f8cff929b267050a62a1cc4248e1b08ae381'
'f4476545086f845e1cec5861169270da9f82a6ad4944972010827a567af0c7d0'
'135faa3f0beb8ecc1b704cf376408e8bd5f62f32ba50a84002c14321d0bb0b68'
- 'daf81142f560db93aeeea96ca185a2662dd0ec9ee220aee167bf826fc44f3dc3')
+ 'daf81142f560db93aeeea96ca185a2662dd0ec9ee220aee167bf826fc44f3dc3'
+ 'fadbacc92c147dead6f09577aedda08aca3a70c04386d91cbee2562739c5645b'
+ '4a65e776ab9092e5828b3c9299add0452b131e1665343bd10758399f67479f47')
prepare() {
cd ${pkgname}-unix-${pkgver}
- sed -i 's#^\(vm_options_path\)=.*$#\1="\${HOME}/CytoscapeConfiguration"#' cytoscape.sh gen_vmoptions.sh
- sed -i '/^LOCAL_CLASSPATH/a KARAF_INSTANCES="\${HOME}/CytoscapeConfiguration/instances"' framework/bin/karaf
- sed -i 's#\${KARAF_HOME}/instances#\${KARAF_INSTANCES}#' framework/bin/karaf
+ patch -p1 -i ../0001-fix-cytoscape.vmoptions-file-location.patch
+ patch -p1 -i ../0002-fix-karaf-instances-dir.patch
}
package() {