summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimdiels2015-09-22 15:03:48 +0200
committertimdiels2015-09-22 15:03:48 +0200
commita2dd1d3569a69cf7c76d65f0962871055280809f (patch)
treee41193276709c2c28bd51e66d632b4badabeaf96
downloadaur-a2dd1d3569a69cf7c76d65f0962871055280809f.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
-rw-r--r--cytoscape3
-rw-r--r--cytoscape.desktop10
-rwxr-xr-xcytoscape.pngbin0 -> 63892 bytes
5 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69055df6ee6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cytoscape
+ pkgdesc = A software for visualizing molecular interaction networks and integration with gene expression profiles and other state data.
+ pkgver = 3.2.1
+ pkgrel = 1
+ url = http://www.cytoscape.org
+ arch = any
+ license = LGPL2
+ depends = java-runtime-common
+ source = http://chianti.ucsd.edu/cytoscape-3.2.1/cytoscape-3.2.1.tar.gz
+ source = cytoscape.desktop
+ source = cytoscape.png
+ source = cytoscape
+ md5sums = 803a8e222291106386877539f9c53e54
+ md5sums = 0a960d9cfb84b986136c2645f4ee4eab
+ md5sums = cbf3c0c062055861c8e2d82105afcc33
+ md5sums = 64521a6620ba82895411c450d4ab639c
+
+pkgname = cytoscape
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8aad6a9635f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: eomarjee <eyaz.omarjee+arch@gmail.com>
+# Contributor: florianbw <florian.bw@gmail.com>
+
+pkgname=cytoscape
+pkgver=3.2.1
+pkgrel=1
+pkgdesc='A software for visualizing molecular interaction networks and integration with gene expression profiles and other state data.'
+arch=('any')
+url=http://www.cytoscape.org
+license=('LGPL2')
+depends=('java-runtime-common')
+source=("http://chianti.ucsd.edu/cytoscape-$pkgver/cytoscape-$pkgver.tar.gz" \
+ 'cytoscape.desktop' \
+ 'cytoscape.png' \
+ 'cytoscape')
+md5sums=('803a8e222291106386877539f9c53e54'
+ '0a960d9cfb84b986136c2645f4ee4eab'
+ 'cbf3c0c062055861c8e2d82105afcc33'
+ '64521a6620ba82895411c450d4ab639c')
+
+build() {
+ cd ${srcdir}/cytoscape-unix-${pkgver}
+ ./gen_vmoptions.sh
+}
+
+package() {
+ install -d ${pkgdir}/opt/cytoscape
+ install -d ${pkgdir}/opt/cytoscape/framework/instances
+ install -d ${pkgdir}/usr/share/{applications,pixmaps}
+ install -d ${pkgdir}/usr/bin
+
+ cd ${startdir}/
+ cp -r ${srcdir}/cytoscape-unix-${pkgver}/* ${pkgdir}/opt/cytoscape
+ chmod 755 ${pkgdir}/opt/cytoscape/cytoscape.sh
+ install -D -m755 cytoscape ${pkgdir}/usr/bin/
+ install -D -m644 cytoscape.png ${pkgdir}/usr/share/pixmaps
+ install -D -m644 cytoscape.desktop ${pkgdir}/usr/share/applications
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cytoscape b/cytoscape
new file mode 100644
index 000000000000..3468b2e8980a
--- /dev/null
+++ b/cytoscape
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/opt/cytoscape/cytoscape.sh $@
diff --git a/cytoscape.desktop b/cytoscape.desktop
new file mode 100644
index 000000000000..84f49ce3d99c
--- /dev/null
+++ b/cytoscape.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=Cytoscape
+GenericName=Cytoscape
+Exec=cytoscape
+Terminal=false
+Icon=cytoscape
+Type=Application
+Categories=Application;Office;
diff --git a/cytoscape.png b/cytoscape.png
new file mode 100755
index 000000000000..8dd68c654006
--- /dev/null
+++ b/cytoscape.png
Binary files differ