summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Bornschein2023-06-12 10:05:29 +0200
committerFabian Bornschein2023-06-12 10:05:29 +0200
commitb32c854af02a35ef2503102aeb260f06a41eec96 (patch)
treef645bfac7cfa29f100d98ef5a78a80113c9458d5
parent85420d95a3ee0aededc8375056303dc751a6120a (diff)
downloadaur-b32c854af02a35ef2503102aeb260f06a41eec96.tar.gz
Use build directory managing cargo-build-dependencies instead of users-home
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06a4d08d3733..0350df2a7f5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = czkawka
pkgdesc = Multi functional app to find duplicates, empty folders, similar images etc.
pkgver = 6.0.0
- pkgrel = 0.1
+ pkgrel = 0.2
url = https://github.com/qarmin/czkawka
arch = aarch64
arch = armv7h
diff --git a/PKGBUILD b/PKGBUILD
index f334c588e16f..30bbbc085eb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=(
czkawka-gui
)
pkgver=6.0.0
-pkgrel=0.1
+pkgrel=0.2
pkgdesc='Multi functional app to find duplicates, empty folders, similar images etc.'
url='https://github.com/qarmin/czkawka'
arch=(
@@ -37,12 +37,18 @@ pkgver() {
build() {
cd ${pkgbase}
+
+ # Keep rust/cargo build-dependency management inside the build directory
+ export CARGO_HOME="${srcdir}/cargo"
+
cargo build --bin czkawka_cli --release --features heif
cargo build --bin czkawka_gui --release --features heif
}
check() {
cd ${pkgbase}
+
+ export CARGO_HOME="${srcdir}/cargo"
cargo test --bin czkawka_cli --release
dbus-run-session xvfb-run -s '-nolisten local' \
cargo test --bin czkawka_gui --release