summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpiritCS2020-10-02 22:57:48 +0200
committerSpiritCS2020-10-02 22:57:48 +0200
commit1304c10cbdee50f0fd4964c6e64a5e7e7c968413 (patch)
treef00d9e78f4b24433e82c300e2f7a08d78822243e
downloadaur-1304c10cbdee50f0fd4964c6e64a5e7e7c968413.tar.gz
new package, typo fix
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD67
-rw-r--r--com.github.qarmin.czkawka.desktop8
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97675b72ab4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = czkawka-git
+ pkgdesc = Multi functional app to find duplicates, empty folders etc.
+ pkgver = 1.0.0.a0c99ab
+ pkgrel = 1
+ url = https://github.com/qarmin/czkawka
+ arch = any
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ depends = gtk3>=3.22
+ provides = czkawa
+ source = czkawka::git+https://github.com/qarmin/czkawka.git
+ source = com.github.qarmin.czkawka.desktop
+ md5sums = SKIP
+ md5sums = beae920d0eb80a8a32832f6f384a3992
+
+pkgname = czkawka-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3797423aaaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+#
+# PKGBUILD file for package czkawa
+#
+# Copyright (C) 2020 sp1rit
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Maintainer: sp1rit <sp1ritCS@protonmail.com>
+
+_basename=czkawka
+pkgname=${_basename}-git
+pkgver=1.0.0.a0c99ab.a0c99ab
+pkgrel=1
+pkgdesc="Multi functional app to find duplicates, empty folders etc."
+arch=(any)
+url="https://github.com/qarmin/czkawka"
+license=('MIT')
+depends=("gtk3>=3.22")
+makedepends=("rust" "cargo")
+provides=("czkawa")
+source=("${_basename}::git+https://github.com/qarmin/czkawka.git" "com.github.qarmin.czkawka.desktop")
+md5sums=("SKIP" "bbc480c6106a7bd7dc73c3cc49a76961")
+
+pkgver() {
+ cd "$srcdir/${_basename}"
+ echo "${pkgver}.$(git rev-parse --short HEAD)"
+}
+
+#prepare() {
+# cd "$pkgname-$pkgver"
+#}
+
+build() {
+ cd "${_basename}/"
+ cargo build --release --bin czkawka_gui
+ cargo build --release --bin czkawka_gui_orbtk
+ cargo build --release --bin czkawka_cli
+}
+
+check() {
+ cd "${_basename}/czkawka_core"
+ cargo test
+}
+
+package() {
+ cd "${_basename}"
+ #ls -lah target/release/
+ install -Dm755 target/release/czkawka_gui $pkgdir/usr/bin/${_basename}_gui
+ install -Dm755 target/release/czkawka_gui_orbtk $pkgdir/usr/bin/${_basename}_gui_orbtk
+ install -Dm755 target/release/czkawka_cli $pkgdir/usr/bin/${_basename}_cli
+
+ ln -s $pkgdir/usr/bin/${_basename}_gui $pkgdir/usr/bin/${_basename}
+
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${_basename}/LICENSE
+ install -Dm644 $srcdir/com.github.qarmin.czkawka.desktop -t $pkgdir/usr/share/applications/
+}
diff --git a/com.github.qarmin.czkawka.desktop b/com.github.qarmin.czkawka.desktop
new file mode 100644
index 000000000000..724cc5ffc5de
--- /dev/null
+++ b/com.github.qarmin.czkawka.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0.0
+Type=Application
+Terminal=false
+Exec=czkawka_gui
+Name=Czkawka
+Comment=Multi functional app to find duplicates, empty folders etc.
+Icon=drive-multidisk