summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-03-18 03:17:11 +0000
committerxiota2024-03-18 03:17:11 +0000
commitee9576d99f1375630cabbbe16d6bbdca3ff6568b (patch)
tree73df2d32f9e2cefd2cb162f6c39f8290e16a7e05
parente9a9ab1ad9e63866056847cb24cc0c0414eaf173 (diff)
downloadaur-ee9576d99f1375630cabbbe16d6bbdca3ff6568b.tar.gz
7.0.0.r4
-rw-r--r--[-rwxr-xr-x].SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--[-rwxr-xr-x]PKGBUILD107
3 files changed, 74 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e70135479bc..a26bdeb168dd 100755..100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = czkawka-git
- pkgdesc = Multi functional app to find duplicates, empty folders etc.
- pkgver = 4.1.0.r16.g56fc29f
+ pkgdesc = Multi-functional app to find duplicates, similar images, and empty folders.
+ pkgver = 7.0.0.r4.g2a32a52
pkgrel = 1
url = https://github.com/qarmin/czkawka
- arch = any
+ arch = x86_64
license = MIT
makedepends = git
makedepends = rust
makedepends = cargo
depends = gtk4
- provides = czkawka
+ provides = czkawka=7.0.0
+ provides = czkawka-cli=7.0.0
+ provides = czkawka-gui=7.0.0
conflicts = czkawka
+ conflicts = czkawka-cli
conflicts = czkawka-gui
- conflicts = czkawka-bin
source = czkawka::git+https://github.com/qarmin/czkawka.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = czkawka-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index c4fab2d35b63..387a3522ed7c 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,62 +1,79 @@
-#
-# PKGBUILD file for package czkawka
-#
-# Copyright (C) 2020 sp1rit
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <https://www.gnu.org/licenses/>.
-
-# Maintainer: sp1rit <sp1ritCS@protonmail.com>
-
-_basename=czkawka
-pkgname=${_basename}-git
-pkgver=4.1.0.r16.g56fc29f
+# Maintainer:
+# Contributor: sp1rit <sp1ritCS@protonmail.com>
+
+_pkgname=czkawka
+pkgname="$_pkgname-git"
+pkgver=7.0.0.r4.g2a32a52
pkgrel=1
-pkgdesc="Multi functional app to find duplicates, empty folders etc."
-arch=(any)
+pkgdesc="Multi-functional app to find duplicates, similar images, and empty folders."
url="https://github.com/qarmin/czkawka"
license=('MIT')
-depends=("gtk4")
-makedepends=("git" "rust" "cargo")
-provides=("czkawka")
-conflicts=("czkawka" "czkawka-gui" "czkawka-bin")
-source=("${_basename}::git+https://github.com/qarmin/czkawka.git")
-md5sums=("SKIP")
+arch=('x86_64')
+
+depends=(
+ "gtk4"
+)
+makedepends=(
+ "git"
+ "rust"
+ "cargo"
+)
+
+provides=(
+ "czkawka=${pkgver%%.r*}"
+ "czkawka-cli=${pkgver%%.r*}"
+ "czkawka-gui=${pkgver%%.r*}"
+)
+conflicts=(
+ "czkawka"
+ "czkawka-cli"
+ "czkawka-gui"
+)
+
+_pkgsrc="$_pkgname"
+source=("$_pkgname"::"git+$url.git")
+sha256sums=("SKIP")
+
+prepare() {
+ export CARGO_HOME="${CARGO_HOME:-$SRCDEST/cargo-home}"
+ export RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable}
+ export CARGO_TARGET_DIR=target
+
+ cd "$_pkgsrc"
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
pkgver() {
- cd "$srcdir/${_basename}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgsrc"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${_basename}/"
- cargo build --release --bin czkawka_gui
- cargo build --release --bin czkawka_cli
+ cd "$_pkgsrc"
+ cargo build --release --bin czkawka_gui
+ cargo build --release --bin czkawka_cli
}
check() {
- cd "${_basename}/czkawka_core"
- cargo test
+ cd "$_pkgsrc/czkawka_core"
+ cargo test
}
package() {
- cd "${_basename}"
- #ls -lah target/release/
- install -Dm755 target/release/czkawka_gui $pkgdir/usr/bin/${_basename}_gui
- install -Dm755 target/release/czkawka_cli $pkgdir/usr/bin/${_basename}_cli
+ cd "$_pkgsrc"
+
+ # binaries
+ install -Dm755 target/release/czkawka_gui -t "$pkgdir/usr/bin/"
+ install -Dm755 target/release/czkawka_cli -t "$pkgdir/usr/bin/"
+
+ # symlink
+ ln -sf "czkawka_gui" "$pkgdir/usr/bin/czkawka"
- ln -s $pkgdir/usr/bin/${_basename}_gui $pkgdir/usr/bin/${_basename}
+ # launcher
+ install -Dm644 data/com.github.qarmin.czkawka.desktop -t "$pkgdir/usr/share/applications/"
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/${_basename}/LICENSE
- install -Dm644 data/com.github.qarmin.czkawka.desktop -t $pkgdir/usr/share/applications/
+ # license
+ for i in czkawka_cli czkawka_core czkawka_gui ; do
+ install -Dm644 "$i/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.$i"
+ done
}