aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Margarido2020-02-05 01:13:55 +0000
committerDaniel Margarido2020-02-05 01:13:55 +0000
commit655ce38742ef49da340efcf903ddb07a56370f57 (patch)
tree5c9ab5051102ded11cb099c0fb097444b1168953
downloadaur-655ce38742ef49da340efcf903ddb07a56370f57.tar.gz
Created the base to setup and install the d-tracker using the AUR.
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD32
-rw-r--r--README.md3
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3cc744f9cb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = d-tracker
+ pkgdesc = Lightweight, cross-platform and simple to setup timetracker. Similar to hamster but uses about 10MB of RAM and has a small quantity of dependencies.
+ pkgver = 0.12.beta.r9.gbba88b0
+ pkgrel = 1
+ url = https://github.com/drmargarido/d-tracker
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = gcc
+ makedepends = automake
+ makedepends = libtool
+ makedepends = git
+ makedepends = libx11
+ makedepends = libxft
+ makedepends = libxext
+ makedepends = libxxf86vm
+ source = git+https://github.com/drmargarido/d-tracker.git
+ md5sums = SKIP
+
+pkgname = d-tracker
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e22b1951651e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 Daniel Margarido
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b246b6ab5802
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Your Name <drmargarido@gmail.com>
+pkgname=d-tracker
+pkgver=0.12.beta.r9.gbba88b0
+pkgrel=1
+pkgdesc="Lightweight, cross-platform and simple to setup timetracker. Similar to hamster but uses about 10MB of RAM and has a small quantity of dependencies."
+arch=("i686" "x86_64")
+url="https://github.com/drmargarido/d-tracker"
+license=('MIT')
+depends=()
+makedepends=("gcc" "automake" "libtool" "git" "libx11" "libxft" "libxext" "libxxf86vm")
+source=("git+https://github.com/drmargarido/d-tracker.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make install INSTALLDIR="${pkgdir}/usr"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..5820b69baba3
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+# D-Tracker AUR Package
+
+[D-Tracker](https://github.com/drmargarido/d-tracker) Arch User Repository Package. This package follows directly the latest git release.