summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormnovick19882016-02-01 21:44:10 -0500
committermnovick19882016-02-01 21:44:10 -0500
commit9bce94e702e19c865ef29e83443fa500f7934c67 (patch)
tree29c4c2f75052a2b0ad5a47651090447c63c0dc2d
downloadaur-9bce94e702e19c865ef29e83443fa500f7934c67.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4483092aa3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 02:42:45 UTC 2016
+pkgbase = d0_blind_id-git
+ pkgdesc = Cryptographic library for identification with Schnorr ID scheme and Blind RSA Signatures
+ pkgver = r129.834b51b
+ pkgrel = 1
+ url = http://github.com/divVerent/d0_blind_id
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = BSD
+ makedepends = git
+ depends = gmp
+ source = git+https://github.com/divVerent/d0_blind_id.git
+ md5sums = SKIP
+
+pkgname = d0_blind_id-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7208721de134
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: M Novick <mnovick1988@gmail.com>
+#
+# Note: Copied and updated from old AUR3.
+#
+
+pkgname=d0_blind_id-git
+pkgver=r129.834b51b
+pkgrel=1
+pkgdesc="Cryptographic library for identification with Schnorr ID scheme and Blind RSA Signatures"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="http://github.com/divVerent/d0_blind_id"
+license=('BSD')
+depends=('gmp')
+makedepends=('git')
+source=("git+https://github.com/divVerent/d0_blind_id.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/d0_blind_id"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/d0_blind_id"
+ sh autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/d0_blind_id"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}