summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-02-19 16:28:04 +0100
committersL1pKn072020-02-19 16:28:04 +0100
commit5e97f874c75c87c512c31cfd6ec86d20672c9213 (patch)
tree35d4fef1c462a87776f2820bbdbc503604d4e4b2
parent861d9074db704b7a1f6cc7df46574e4c60a3f949 (diff)
downloadaur-5e97f874c75c87c512c31cfd6ec86d20672c9213.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 077760cc152f..cf3e96c2d54d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
-# Generated by mksrcinfo v8
-# Wed Apr 11 21:06:03 UTC 2018
pkgbase = d2vwitch-git
pkgdesc = Cross-platform D2V creator. (GIT version)
- pkgver = v2.7.g82502e7
+ pkgver = v3.3.gbd0b13b
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=173090
arch = x86_64
license = LGPL2.1
license = ISC
makedepends = git
+ makedepends = meson
depends = vapoursynth
depends = libavutil.so
depends = libavformat.so
diff --git a/PKGBUILD b/PKGBUILD
index 670ba2c749dd..3a57a4f3ead8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=d2vwitch-git
-pkgver=v2.7.g82502e7
+pkgver=v3.3.gbd0b13b
pkgrel=1
pkgdesc="Cross-platform D2V creator. (GIT version)"
arch=('x86_64')
@@ -15,7 +15,9 @@ depends=('vapoursynth'
'qt5-base'
'xdg-utils'
)
-makedepends=('git')
+makedepends=('git'
+ 'meson'
+ )
provides=('d2vwitch')
conflicts=('d2vwitch')
source=('d2vwitch::git+https://github.com/dubhater/D2VWitch.git'
@@ -31,19 +33,19 @@ pkgver() {
}
prepare() {
- cd d2vwitch
- ./autogen.sh
+ mkdir -p build
}
build() {
- cd d2vwitch
- ./configure \
- --prefix=/usr
- make
+ cd build
+ arch-meson ../d2vwitch \
+ --libdir /usr/lib/vapoursynth
+
+ LC_ALL=C ninja
}
-package() {
- make -C d2vwitch DESTDIR="${pkgdir}" install
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
install -Dm644 "${srcdir}/d2vwitch.desktop" "${pkgdir}/usr/share/applications/d2vwitch.desktop"