summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-07-30 12:09:15 +0200
committerGustavo Alvarez2016-07-30 12:09:28 +0200
commitbb7acfd5aafaa1b4a55955dc2a5336d679c328b0 (patch)
treec99ad40698270619981ed832055853c8d4a2ab2d
parent182faeacd9b78b99568809829564736b6c9d25ce (diff)
downloadaur-bb7acfd5aafaa1b4a55955dc2a5336d679c328b0.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
-rwxr-xr-xd2vwitch.desktop10
4 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e28b26d9b9a..94e051e43c99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jan 17 01:33:53 UTC 2016
+# Sat Jul 30 10:09:03 UTC 2016
pkgbase = d2vwitch-git
pkgdesc = Cross-platform D2V creator. (GIT version)
- pkgver = v1.0.gb9b26a9
+ pkgver = v1.11.ga045c62
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=173090
arch = i686
@@ -14,9 +14,11 @@ pkgbase = d2vwitch-git
depends = libavformat.so
depends = libavcodec.so
depends = gcc-libs
+ depends = qt5-base
provides = d2vwitch
conflicts = d2vwitch
source = d2vwitch::git+https://github.com/dubhater/D2VWitch.git
+ source = d2vwitch.desktop
sha1sums = SKIP
pkgname = d2vwitch-git
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..619b17da6aa2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!d2vwitch.desktop
diff --git a/PKGBUILD b/PKGBUILD
index cdb08bfc6ed9..41f33e04b7b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=d2vwitch-git
-pkgver=v1.0.gb9b26a9
+pkgver=v1.11.ga045c62
pkgrel=1
pkgdesc="Cross-platform D2V creator. (GIT version)"
arch=('i686' 'x86_64')
@@ -11,11 +11,13 @@ depends=('libavutil.so'
'libavformat.so'
'libavcodec.so'
'gcc-libs'
+ 'qt5-base'
)
makedepends=('git')
provides=('d2vwitch')
conflicts=('d2vwitch')
-source=('d2vwitch::git+https://github.com/dubhater/D2VWitch.git')
+source=('d2vwitch::git+https://github.com/dubhater/D2VWitch.git'
+ 'd2vwitch.desktop')
sha1sums=('SKIP')
pkgver() {
@@ -30,10 +32,13 @@ prepare() {
build() {
cd d2vwitch
- ./configure --prefix=/usr
+ ./configure \
+ --prefix=/usr
make
}
package() {
make -C d2vwitch DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${srcdir}/d2vwitch.desktop" "${pkgdir}/usr/share/applications/d2vwitch.desktop"
}
diff --git a/d2vwitch.desktop b/d2vwitch.desktop
new file mode 100755
index 000000000000..8e4bc3781613
--- /dev/null
+++ b/d2vwitch.desktop
@@ -0,0 +1,10 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Name=D2VWitch
+GenericName=Indexes MPEG (1, 2) streams and writes D2V files
+Comment=Indexes MPEG (1, 2) streams and writes D2V files
+Type=Application
+Exec=d2vwitch
+Terminal=false
+StartupNotify=false
+Categories=AudioVideo;