summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-08-09 12:23:42 +0200
committerNarrat2015-08-09 12:23:42 +0200
commitf5f9f2f60a8ab19158525c2f2a54762c59e7cb42 (patch)
tree9f8fda391d990c67966a58649ed0374b78887684
parent015cc5fc80baea15ebd29ed2444f4c63ddc76352 (diff)
downloadaur-f5f9f2f60a8ab19158525c2f2a54762c59e7cb42.tar.gz
daala: Update PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD45
3 files changed, 61 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29008c6eb49a..eb318e394c00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,24 @@
pkgbase = daala-git
- pkgdesc = Daala is next-next-gen video compression technology from Xiph.org, Mozilla and others.
- pkgver = 556.f79a2f0
- pkgrel = 2
+ pkgdesc = next-next-gen video compression technology from Xiph.org, Mozilla and others
+ pkgver = 0.0.r1115.g3125a5b
+ pkgrel = 1
url = https://www.xiph.org/daala/
arch = i686
arch = x86_64
license = BSD
+ checkdepends = check
makedepends = git
- makedepends = check
+ makedepends = sdl2
+ makedepends = wxgtk
depends = libogg
depends = libpng
+ depends = libjpeg-turbo
+ optdepends = sdl2: For daala example player
+ optdepends = wxgtk: For daala example analyzer
provides = libdaala
+ provides = daala
conflicts = libdaala
+ conflicts = daala
options = !libtool
source = git://git.xiph.org/daala.git
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..47eb7e8d731a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*.asc
+*.bz2
+daala/
+*.gz
+*.log
+*.part
+*.pkg
+pkg/
+*.scm
+*.sig
+*.sign
+src/
+*.txt
+*.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 19964b725492..401dc00f7c60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,55 @@
+# Maintainer: Lex Black <autumn-wind at web dot de>
+# Contributor: Who uploaded it to AUR3
+
_gitname=daala
-#pkgname=libdaala-git # Former AUR3 name
pkgname=${_gitname}-git
-pkgver=556.f79a2f0
-pkgver() { cd $_gitname && echo $(git rev-list --count master).$(git rev-parse --short master); }
-pkgrel=2
-pkgdesc="Daala is next-next-gen video compression technology from Xiph.org, Mozilla and others."
+pkgver=0.0.r1115.g3125a5b
+pkgrel=1
+pkgdesc="next-next-gen video compression technology from Xiph.org, Mozilla and others"
arch=('i686' 'x86_64')
url="https://www.xiph.org/daala/"
license=('BSD')
-depends=('libogg' 'libpng')
-makedepends=('git' 'check')
-provides=('libdaala')
-conflicts=('libdaala')
+depends=('libogg' 'libpng' 'libjpeg-turbo')
+makedepends=('git' 'sdl2' 'wxgtk')
+checkdepends=('check')
+optdepends=("sdl2: For daala example player"
+ "wxgtk: For daala example analyzer")
+provides=('libdaala' $_gitname)
+conflicts=('libdaala' $_gitname)
options=('!libtool')
source=('git://git.xiph.org/daala.git')
md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//'
+}
+
build() {
cd $_gitname
./autogen.sh
- ./configure --prefix=/usr --libdir=/usr/lib
+ ./configure --prefix=/usr --libdir=/usr/lib --enable-analyzer --enable-accounting
make
+ #make tools
+}
+
+check() {
+ cd $_gitname
+ make check
}
package() {
cd $_gitname
make DESTDIR="$pkgdir/" install
+ #make DESTDIR="$pkgdir/" install-docs
+ #make DESTDIR="$pkgdir/" install-exec
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+
+ # Install the example programs (if someone want to, some do work, outside of build directory)
+ #install -Dm644 $pkgdir/usr/bin
+ #install -m755 examples/analyzer ${pkgdir}/usr/bin/daala-analyzer
+ #install -m755 examples/encoder_example ${pkgdir}/usr/bin/daala-encoder-ex
+ #install -m755 examples/dump_video ${pkgdir}/usr/bin/daala-dump-video
+ #install -m755 examples/player_example ${pkgdir}/usr/bin/daala-player-ex
}