summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Scarpino2015-12-24 11:24:11 +0100
committerAndrea Scarpino2015-12-24 11:24:11 +0100
commit48a745fcaf678a0b518cb6e4bbdf6a95c7eb3287 (patch)
tree76650af9eff83446aea5be35a2d9d37478d55035
downloadaur-48a745fcaf678a0b518cb6e4bbdf6a95c7eb3287.tar.gz
First, imported from old AUR
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD45
-rw-r--r--daemontools-0.76.errno.patch12
-rw-r--r--daemontools-0.76.svscanboot-path-fix.patch12
-rw-r--r--daemontools.install8
-rw-r--r--svscan.service10
6 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bb4be81d1a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Thu Dec 24 10:23:53 UTC 2015
+pkgbase = daemontools
+ pkgdesc = A collection of tools for managing UNIX services
+ pkgver = 0.76
+ pkgrel = 7
+ url = http://cr.yp.to/daemontools.html
+ install = daemontools.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = public domain
+ depends = pacman
+ source = http://cr.yp.to/daemontools/daemontools-0.76.tar.gz
+ source = http://smarden.org/pape/djb/manpages/daemontools-0.76-man.tar.gz
+ source = daemontools-0.76.errno.patch
+ source = daemontools-0.76.svscanboot-path-fix.patch
+ source = svscan.service
+ md5sums = 1871af2453d6e464034968a0fbcb2bfc
+ md5sums = 2d3858a48f293c87202f76cd883438ee
+ md5sums = 1ab80be37239e920542425baa8f1c5b9
+ md5sums = 55ee6f55f01e9df3c432ac764875087e
+ md5sums = 8915bb319b7cf68376ee51a356b87f88
+
+pkgname = daemontools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ef4e856344b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: jianingy <jianingy.yang AT gmail.com>
+# Contributor: cmb <chris AT the-brannons.com>
+# Contributor: hatred <hatred AT inbox.ru>
+
+pkgname=daemontools
+pkgrel=7
+pkgver=0.76
+pkgdesc='A collection of tools for managing UNIX services'
+arch=(i686 x86_64 armv6h)
+url='http://cr.yp.to/daemontools.html'
+license=('public domain')
+depends=('pacman')
+backups=('/etc/inittab')
+install=daemontools.install
+source=(
+ "http://cr.yp.to/daemontools/$pkgname-$pkgver.tar.gz"
+ "http://smarden.org/pape/djb/manpages/$pkgname-$pkgver-man.tar.gz"
+ 'daemontools-0.76.errno.patch'
+ 'daemontools-0.76.svscanboot-path-fix.patch'
+ 'svscan.service'
+)
+md5sums=(
+ '1871af2453d6e464034968a0fbcb2bfc'
+ '2d3858a48f293c87202f76cd883438ee'
+ '1ab80be37239e920542425baa8f1c5b9'
+ '55ee6f55f01e9df3c432ac764875087e'
+ '8915bb319b7cf68376ee51a356b87f88'
+)
+
+build() {
+ cd admin/$pkgname-$pkgver
+ patch -p1 < $srcdir/daemontools-0.76.errno.patch
+ patch -p1 < $srcdir/daemontools-0.76.svscanboot-path-fix.patch
+ package/compile
+}
+
+package() {
+ cd admin/$pkgname-$pkgver
+ install -d $pkgdir/usr/bin
+ cp -a command/* $pkgdir/usr/bin
+ install -d $pkgdir/usr/share/man/man8
+ cp -a $srcdir/daemontools-man/* $pkgdir/usr/share/man/man8
+ install -d $pkgdir/usr/lib/systemd/system
+ install -m644 $srcdir/svscan.service $pkgdir/usr/lib/systemd/system
+}
diff --git a/daemontools-0.76.errno.patch b/daemontools-0.76.errno.patch
new file mode 100644
index 000000000000..d1884f579760
--- /dev/null
+++ b/daemontools-0.76.errno.patch
@@ -0,0 +1,12 @@
+diff -ur daemontools-0.76.old/src/error.h daemontools-0.76/src/error.h
+--- daemontools-0.76.old/src/error.h 2001-07-12 11:49:49.000000000 -0500
++++ daemontools-0.76/src/error.h 2003-01-09 21:52:01.000000000 -0600
+@@ -3,7 +3,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
diff --git a/daemontools-0.76.svscanboot-path-fix.patch b/daemontools-0.76.svscanboot-path-fix.patch
new file mode 100644
index 000000000000..0d176efe2bd3
--- /dev/null
+++ b/daemontools-0.76.svscanboot-path-fix.patch
@@ -0,0 +1,12 @@
+diff -Nur daemontools-0.76.old/src/svscanboot.sh daemontools-0.76/src/svscanboot.sh
+--- daemontools-0.76.old/src/svscanboot.sh 2001-07-13 00:49:49.000000000 +0800
++++ daemontools-0.76/src/svscanboot.sh 2009-11-07 23:46:47.000000000 +0800
+@@ -5,7 +5,7 @@
+ exec >/dev/null
+ exec 2>/dev/null
+
+-/command/svc -dx /service/* /service/*/log
++/usr/bin/svc -dx /service/* /service/*/log
+
+ env - PATH=$PATH svscan /service 2>&1 | \
+ env - PATH=$PATH readproctitle service errors: ................................................................................................................................................................................................................................................................................................................................................................................................................
diff --git a/daemontools.install b/daemontools.install
new file mode 100644
index 000000000000..599ec2250586
--- /dev/null
+++ b/daemontools.install
@@ -0,0 +1,8 @@
+post_install() {
+ systemctl start svscan
+}
+
+post_remove() {
+ systemctl stop svscan
+}
+
diff --git a/svscan.service b/svscan.service
new file mode 100644
index 000000000000..81dec755874f
--- /dev/null
+++ b/svscan.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=svscan service of daemontools
+After=syslog.target
+
+[Service]
+ExecStart=/usr/bin/svscanboot
+Restart=always
+
+[Install]
+WantedBy=multi-user.target