summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Zok2024-03-21 14:57:40 +0100
committerTomasz Zok2024-03-21 14:57:40 +0100
commiteb802f1067365857a58070a288673f94c9281555 (patch)
treedb51d1a9b90d0e5bee400d1c527f6e45fd20645b
parenteef213597c51ea9aeaac49470722323bdb210e29 (diff)
downloadaur-eb802f1067365857a58070a288673f94c9281555.tar.gz
Update to the latest version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD61
-rw-r--r--dafs.patch10
3 files changed, 56 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c26db77cc65..c7affdef4dd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = dafs-git
- pkgdesc = DAFS: simultaneous aligning and folding of RNA sequences by dual decomposition
- pkgver = 0.0.2.6.g8b19266
+ pkgdesc = dual decomposition for aligning and folding RNA sequences simultaneously
+ pkgver = r108.e9cc15c
pkgrel = 1
url = https://github.com/satoken/dafs
- arch = i686
arch = x86_64
license = GPL
- makedepends = git
- depends = boost
- depends = glpk
- depends = viennarna2
- source = git://github.com/satoken/dafs.git
- md5sums = SKIP
+ makedepends = cmake
+ depends = viennarna
+ optdepends = glpk: solver for linear programming
+ source = git+https://github.com/satoken/dafs
+ source = git+https://github.com/jarro2783/cxxopts
+ source = git+https://github.com/gabime/spdlog
+ source = dafs.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 6147313855a24ff6b624a16318460e1b8eaae5087afc93460ca75717193185dd
pkgname = dafs-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4c22f45495e9..417426008c07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,47 @@
-# Maintainer: Keith Hughitt <khughitt@umd.edu>
+# Maintainer: Tomasz Zok <tomasz dot zok at gmail dot com>
pkgname=dafs-git
-_gitname=dafs
-pkgver=0.0.2.6.g8b19266
+pkgver=r108.e9cc15c
pkgrel=1
-pkgdesc="DAFS: simultaneous aligning and folding of RNA sequences by dual
-decomposition"
-arch=('i686' 'x86_64')
+pkgdesc="dual decomposition for aligning and folding RNA sequences simultaneously"
+arch=(x86_64)
url="https://github.com/satoken/dafs"
license=('GPL')
-makedepends=('git')
-depends=('boost' 'glpk' 'viennarna2')
-md5sums=("SKIP")
-
-source=("git://github.com/satoken/dafs.git")
+depends=(viennarna)
+makedepends=(cmake)
+optdepends=('glpk: solver for linear programming')
+source=("git+https://github.com/satoken/${pkgname%-git}"
+ "git+https://github.com/jarro2783/cxxopts"
+ "git+https://github.com/gabime/spdlog"
+ "dafs.patch")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ '6147313855a24ff6b624a16318460e1b8eaae5087afc93460ca75717193185dd')
pkgver() {
- cd "${srcdir}/${_gitname}"
- git describe --tags | sed -e 's:v::' -e 's/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- cd "$srcdir/$_gitname"
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git config submodule.libs/cxxopts.url "$srcdir/cxxopts"
+ git config submodule.libs/spdlog.url "$srcdir/spdlog"
+ git -c protocol.file.allow=always submodule update
- env CXXFLAGS='-fopenmp' ./configure --prefix=/usr --with-vienna-rna=/usr/include/ViennaRNA --with-glpk
-
- # https://github.com/SIPp/sipp/issues/61
- touch configure.ac aclocal.m4 configure Makefile.am Makefile.in
+ patch -p0 -i "$srcdir/${pkgname%-git}.patch"
+}
- make CXXFLAGS="-Wall -O2 -fpermissive -fopenmp" CFLAGS="$CFLAGS -I/usr/include/ViennaRNA" PREFIX=/usr
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p build
+ cd build
+ cmake ..
+ make
}
package() {
- cd "$srcdir/$_gitname"
-
- #make PREFIX="$pkgdir/usr" install
- make install DESTDIR="$pkgdir"
-
- # install license
- install -D -m644 "COPYING" "$pkgdir/usr/share/licenses/$_gitname/LICENSE"
+ cd "$srcdir/${pkgname%-git}/build"
+ make DESTDIR="$pkgdir/" install
}
-
diff --git a/dafs.patch b/dafs.patch
new file mode 100644
index 000000000000..e34b563db281
--- /dev/null
+++ b/dafs.patch
@@ -0,0 +1,10 @@
+--- src/needleman_wunsch.cpp.orig 2024-03-21 14:20:56.061266948 +0100
++++ src/needleman_wunsch.cpp 2024-03-21 14:21:11.028166421 +0100
+@@ -24,6 +24,7 @@
+ #include "needleman_wunsch.h"
+ #include <cassert>
+ #include <algorithm>
++#include <limits>
+
+ float
+ NeedlemanWunsch::