summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher RYU2021-05-20 10:04:58 +0900
committerChristopher RYU2021-05-20 10:04:58 +0900
commite38defb321774f8eeee89e243409d459fe0741fe (patch)
treeac112279bb3dbc795bc45aca54d88157d233a79d
downloadaur-e38defb321774f8eeee89e243409d459fe0741fe.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f91e6f6f2aa5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dahdi-linux-ck-git-dkms
+ pkgdesc = DAHDI drivers for Asterisk, patched to support older cards
+ pkgver = git
+ pkgrel = 1
+ url = http://www.asterisk.org/
+ arch = i686
+ arch = x86_64
+ license = LGPLv2
+ makedepends = linux-headers
+ depends = dkms
+ conflicts = dahdi
+ source = git+https://github.com/christopherkobayashi/dahdi-linux.git
+ sha256sums = SKIP
+
+pkgname = dahdi-linux-ck-git-dkms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3463f1c40fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Christopher KOBAYASHI <software plus aur at disavowed dot jp>
+
+pkgname="dahdi-linux-ck-git-dkms"
+pkgdesc="DAHDI drivers for Asterisk, patched to support older cards"
+pkgver=git
+pkgrel=1
+arch=("i686" "x86_64")
+url="http://www.asterisk.org/"
+license=("LGPLv2")
+depends=('dkms')
+makedepends=("linux-headers")
+conflicts=("dahdi")
+source=("git+https://github.com/christopherkobayashi/dahdi-linux.git")
+
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}"
+ local install_dir="${pkgdir}/usr/src/dahdi-linux-${pkgver}"
+
+ # Copy sources
+ cp -r "${srcdir}"/dahdi-linux/* "${install_dir}"/
+}