summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher RYU2022-05-26 11:23:02 +0900
committerChristopher RYU2022-05-26 11:23:02 +0900
commite99450ab1e31bf87952d8b941b274758fef0d6d6 (patch)
treeb8200e18feaaad6f4d595aa19abfb3addc5b9894
parente38defb321774f8eeee89e243409d459fe0741fe (diff)
downloadaur-e99450ab1e31bf87952d8b941b274758fef0d6d6.tar.gz
Use proper git versioning.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f91e6f6f2aa5..2eaaaa5f2038 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dahdi-linux-ck-git-dkms
pkgdesc = DAHDI drivers for Asterisk, patched to support older cards
- pkgver = git
+ pkgver = 20220326.g9b3d416
pkgrel = 1
url = http://www.asterisk.org/
arch = i686
@@ -13,4 +13,3 @@ pkgbase = dahdi-linux-ck-git-dkms
sha256sums = SKIP
pkgname = dahdi-linux-ck-git-dkms
-
diff --git a/PKGBUILD b/PKGBUILD
index c3463f1c40fe..a5098b7fd1f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="dahdi-linux-ck-git-dkms"
pkgdesc="DAHDI drivers for Asterisk, patched to support older cards"
-pkgver=git
+pkgver=20220326.g9b3d416
pkgrel=1
arch=("i686" "x86_64")
url="http://www.asterisk.org/"
@@ -14,6 +14,11 @@ source=("git+https://github.com/christopherkobayashi/dahdi-linux.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/dahdi-linux"
+ git log -1 --format="%cd.g%h" --date=short | sed 's/-//g'
+}
+
package() {
cd "${srcdir}"
local install_dir="${pkgdir}/usr/src/dahdi-linux-${pkgver}"