summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122020-06-14 07:54:56 +0200
committerwillemw122020-06-14 07:54:56 +0200
commit18228ef168baf0efbb7b244587eb2d2f8e7108e3 (patch)
tree476c95f5f22834edccfa78f1927c7c1194077faa
downloadaur-18228ef168baf0efbb7b244587eb2d2f8e7108e3.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD25
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc16063050c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = daily-wallpaper-git
+ pkgdesc = Change wallpaper automatically with the Photo of The Day of you loved source
+ pkgver = r82.0b5e9e0
+ pkgrel = 1
+ url = https://github.com/atareao/daily-wallpaper
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = python-gobject
+ depends = python-lxml
+ depends = python-cssselect
+ depends = python-requests
+ depends = python-crontab
+ depends = python-plumbum
+ depends = gtk3
+ depends = libnotify
+ provides = daily-wallpaper
+ conflicts = daily-wallpaper
+ source = daily-wallpaper-git::git+https://github.com/atareao/daily-wallpaper.git
+ md5sums = SKIP
+
+pkgname = daily-wallpaper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db928b7ab650
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+pkgname=daily-wallpaper-git
+pkgver=r82.0b5e9e0
+pkgrel=1
+pkgdesc="Change wallpaper automatically with the Photo of The Day of you loved source"
+arch=('x86_64')
+url="https://github.com/atareao/daily-wallpaper"
+license=('MIT')
+depends=('python-gobject' 'python-lxml' 'python-cssselect' 'python-requests' 'python-crontab' 'python-plumbum' 'gtk3' 'libnotify')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $pkgname
+}
+