summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122020-06-14 11:06:04 +0200
committerwillemw122020-06-14 11:06:04 +0200
commit9830150c576610c35f1a90f1d9e370056a903c35 (patch)
tree0be520b3146b1ecde08dd0a10de5a8b5e8656521
parent18228ef168baf0efbb7b244587eb2d2f8e7108e3 (diff)
downloadaur-9830150c576610c35f1a90f1d9e370056a903c35.tar.gz
Second commit
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc16063050c1..735f5a9b4cb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,8 +14,11 @@ pkgbase = daily-wallpaper-git
depends = python-plumbum
depends = gtk3
depends = libnotify
+ optdepends = cron: automatic download
provides = daily-wallpaper
+ provides = national-geographic-wallpaper
conflicts = daily-wallpaper
+ conflicts = national-geographic-wallpaper
source = daily-wallpaper-git::git+https://github.com/atareao/daily-wallpaper.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index db928b7ab650..086caaecbd0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,10 @@ arch=('x86_64')
url="https://github.com/atareao/daily-wallpaper"
license=('MIT')
depends=('python-gobject' 'python-lxml' 'python-cssselect' 'python-requests' 'python-crontab' 'python-plumbum' 'gtk3' 'libnotify')
+optdepends=('cron: automatic download')
makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}" 'national-geographic-wallpaper')
+conflicts=("${pkgname%-git}" 'national-geographic-wallpaper')
source=("$pkgname::git+$url.git")
md5sums=('SKIP')
@@ -21,5 +22,20 @@ pkgver() {
package() {
cd $pkgname
+
+ install -dm755 "$pkgdir/usr"
+ cp -a bin "$pkgdir/usr"
+
+ install -dm755 "$pkgdir/usr/share/daily-wallpaper"
+ cp -a src/*.py "$pkgdir/usr/share/daily-wallpaper"
+
+ install -dm755 "$pkgdir/usr/share/daily-wallpaper"
+ cp -a src/dailies "$pkgdir/usr/share/daily-wallpaper"
+
+ install -dm755 "$pkgdir/usr/share/icons"
+ cp -a data/icons/hicolor "$pkgdir/usr/share/icons"
+
+ install -dm755 "$pkgdir/usr/share/applications"
+ cp -a data/daily-wallpaper.desktop "$pkgdir/usr/share/applications"
}