summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302017-01-18 17:57:09 +0100
committerM0Rf302017-01-18 17:57:09 +0100
commitee533ce79c635289809c4be5869e917a9d238b2d (patch)
treee2b933d0000fba14ae459920945ae5a738d2413c
downloadaur-ee533ce79c635289809c4be5869e917a9d238b2d.tar.gz
first commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f455f26da019
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Jan 18 16:57:01 UTC 2017
+pkgbase = dakota
+ pkgdesc = A flexible, extensible interface between analysis codes and iterative systems analysis methods
+ pkgver = 6.5.0
+ pkgrel = 1
+ url = https://dakota.sandia.gov/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = gcc-fortran
+ makedepends = python2
+ depends = boost
+ depends = icu
+ depends = lapack
+ options = !strip
+ source = https://dakota.sandia.gov/sites/default/files/distributions/public/dakota-6.5-public.src.tar.gz
+ md5sums = 02c46e904d40bba6b308065db34c1ad7
+
+pkgname = dakota
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee627cf38eeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: M0Rf30
+
+pkgname=dakota
+pkgver=6.5.0
+pkgrel=1
+pkgdesc="A flexible, extensible interface between analysis codes and iterative systems analysis methods"
+arch=(i686 x86_64)
+url="https://dakota.sandia.gov/"
+license=('LGPL')
+depends=('boost' 'icu' 'lapack')
+makedepends=('cmake' 'gcc-fortran' 'python2')
+options=(!strip)
+source=("https://dakota.sandia.gov/sites/default/files/distributions/public/$pkgname-6.5-public.src.tar.gz")
+
+build() {
+ cd "$srcdir/$pkgname-${pkgver}.src"
+ mkdir build
+ cd build
+ cmake .. -Wno-dev -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DDAKOTA_F90=OFF
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-${pkgver}.src"
+ cd build
+ make DESTDIR=$pkgdir install
+ rm $pkgdir/usr/include/{cblas.h,tinystr.h,tinyxml.h}
+ rm $pkgdir/usr/lib/libtinyxml.so
+}
+
+md5sums=('02c46e904d40bba6b308065db34c1ad7')