summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Symon2017-05-06 23:15:11 +1200
committerJeremy Symon2017-05-06 23:22:47 +1200
commit042eb664ad045eea6717ee75ab4ed9c3006694d9 (patch)
tree9be622b7af0ba051ac14ab0066e5eb3214f6c556
parent5ae5cebd33fd01503eda44bf4de0643bf079a50f (diff)
downloadaur-042eb664ad045eea6717ee75ab4ed9c3006694d9.tar.gz
Removed mandir patch: it got merged upstream
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--cmake-mandir.patch24
3 files changed, 2 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04a681514438..6f4f741dd4b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dale-git
pkgdesc = Lisp-flavoured C
- pkgver = r1036.933e671
+ pkgver = r1038.760bb29
pkgrel = 1
url = https://github.com/tomhrr/dale/
arch = x86_64
@@ -16,9 +16,7 @@ pkgbase = dale-git
depends = ncurses
provides = dale
source = git+https://github.com/tomhrr/dale.git
- source = cmake-mandir.patch
sha512sums = SKIP
- sha512sums = dedff6224c9b19d821dc47b8ecf55e2444cf160320b9bcdc8343699575cf6ec4da402ee7d2a9341c491e62b9f179d458c1d01efad226fc09e283f3c2a6fac2a2
pkgname = dale-git
diff --git a/PKGBUILD b/PKGBUILD
index 66a35f52120c..620b98aec413 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jeremy Symon <jtsymon@gmail.com>
pkgname=dale-git
_gitname=dale
-pkgver=r1036.933e671
+pkgver=r1038.760bb29
pkgrel=1
pkgdesc='Lisp-flavoured C'
url='https://github.com/tomhrr/dale/'
@@ -12,11 +12,9 @@ makedepends=('git' 'cmake' 'pkg-config' 'llvm35')
provides=('dale')
source=(
"git+https://github.com/tomhrr/${_gitname}.git"
- "cmake-mandir.patch"
)
sha512sums=(
'SKIP'
- 'dedff6224c9b19d821dc47b8ecf55e2444cf160320b9bcdc8343699575cf6ec4da402ee7d2a9341c491e62b9f179d458c1d01efad226fc09e283f3c2a6fac2a2'
)
pkgver() {
@@ -24,11 +22,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$_gitname"
- patch -Np1 -i "${srcdir}/cmake-mandir.patch"
-}
-
build() {
mkdir -p build
cd build
diff --git a/cmake-mandir.patch b/cmake-mandir.patch
deleted file mode 100644
index 981d478b180b..000000000000
--- a/cmake-mandir.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 61648a9..e30b9df 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -44,6 +44,10 @@ set (D_LLVM_VERSION_MAJOR "${D_LLVM_VERSION_MAJOR}")
- set (D_LLVM_VERSION_MINOR "${D_LLVM_VERSION_MINOR}")
- set (LLVM_BIN_DIR "${LLVM_BIN_DIR}")
-
-+if (NOT CMAKE_INSTALL_MANDIR)
-+ set (CMAKE_INSTALL_MANDIR "${CMAKE_INSTALL_PREFIX}/man")
-+endif ()
-+
- if (NOT CC)
- if (CLANG)
- set (CC "${CLANG}")
-@@ -319,7 +323,7 @@ add_dependencies (tests dalec cstdio cstring pthread cfloat ctype cerrno ctime c
- # Manfile for the compiler.
-
- add_custom_target (documentation ALL DEPENDS man/dalec.1.gz)
--install (FILES man/dalec.1.gz DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
-+install (FILES man/dalec.1.gz DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
-
- # Dale programs. (module-to-markdown was previously built with
- # --static-modules, but there's a problem with that option in some