summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2024-08-25 20:49:03 +0200
committerMartin Diehl2024-08-25 20:49:03 +0200
commit3716493eed59f167c272f4f553d7d113aa55ef3e (patch)
tree3a63708c3460ad9e02302a5b542efa5611b64c13
parent6e48ae30c8205c73c3c63271726b40456a8c1da3 (diff)
downloadaur-3716493eed59f167c272f4f553d7d113aa55ef3e.tar.gz
corrected dependencies
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD6
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1f33a8b7dc8..2fa0ec87d9e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = damask
pkgdesc = DAMASK - The Duesseldorf Advanced Material Simulation Kit
pkgver = 3.0.0
- pkgrel = 1
- url = https://damask.mpie.de
+ pkgrel = 3
+ url = https://damask-multiphysics.org
arch = x86_64
license = AGPL-3.0-or-later
makedepends = cmake
@@ -12,13 +12,15 @@ pkgbase = damask
makedepends = fftw-openmpi
makedepends = zlib
makedepends = libfyaml
- makedepends = python-matplotlib
- makedepends = python-scipy
makedepends = python-pandas
+ makedepends = python-numpy
+ makedepends = python-scipy
makedepends = python-h5py
+ makedepends = vtk
+ makedepends = python-matplotlib
makedepends = python-pyaml
optdepends = paraview: post-processing
- source = https://damask.mpie.de/download/damask-3.0.0.tar.xz
+ source = https://damask-multiphysics.org/download/damask-3.0.0.tar.xz
sha512sums = f8e2f398c558f90ed4cac8fa60d57bd179a98f1d437ed0b5a5bd9801354cf74f12dba40551dbeabe00ad6e53709bd2daa3b64f759f3170c4766d8795d3f76483
pkgname = damask
@@ -46,10 +48,12 @@ pkgname = damask-mesh
pkgname = python-damask
pkgdesc = Pre- and post-processing tools for DAMASK
- depends = python-matplotlib
- depends = python-scipy
depends = python-pandas
+ depends = python-numpy
+ depends = python-scipy
depends = python-h5py
+ depends = vtk
+ depends = python-matplotlib
depends = python-pyaml
optdepends = python-seaborn: post-processing
optdepends = jupyterlab: comfortable shell
diff --git a/PKGBUILD b/PKGBUILD
index 984984addd7c..4f083c995991 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgbase=damask
pkgname=('damask' 'damask-grid' 'damask-mesh' 'python-damask')
pkgver=3.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='DAMASK - The Duesseldorf Advanced Material Simulation Kit'
arch=('x86_64')
url='https://damask-multiphysics.org'
license=('AGPL-3.0-or-later')
makedepends=('cmake' 'python-setuptools'
'petsc<3.22' 'hdf5-openmpi' 'fftw-openmpi' 'zlib' 'libfyaml'
- 'python-matplotlib' 'python-scipy' 'python-pandas' 'python-h5py' 'python-pyaml')
+ 'python-pandas' 'python-numpy' 'python-scipy' 'python-h5py' 'vtk' 'python-matplotlib' 'python-pyaml')
optdepends=('paraview: post-processing')
source=(https://damask-multiphysics.org/download/damask-${pkgver}.tar.xz)
@@ -86,7 +86,7 @@ package_damask-mesh() {
package_python-damask() {
pkgdesc='Pre- and post-processing tools for DAMASK'
- depends=('python-matplotlib' 'python-scipy' 'python-pandas' 'python-h5py' 'python-pyaml')
+ depends=('python-pandas' 'python-numpy' 'python-scipy' 'python-h5py' 'vtk' 'python-matplotlib' 'python-pyaml')
optdepends=('python-seaborn: post-processing'
'jupyterlab: comfortable shell'
'ipython: comfortable shell')