summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2022-10-10 12:22:15 +0200
committerMartin Diehl2022-10-10 12:22:30 +0200
commit5db7735f158ed16bfb9d7d65f2215a082305a79e (patch)
tree75f903f8ddf6e5d5765ab7da05beb89994a4d696
parentcb4c89af11f5bc295486680a28cd9a76b2dbded7 (diff)
downloadaur-5db7735f158ed16bfb9d7d65f2215a082305a79e.tar.gz
3.0.0~alpha7
-rw-r--r--.SRCINFO14
-rw-r--r--0001-PETSc-3.17.1-backport.patch56
-rw-r--r--CMakeLists.patch21
-rw-r--r--PKGBUILD24
-rw-r--r--setup.patch11
5 files changed, 52 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4757cccc6b8..9b89a5d52f6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = damask
pkgdesc = DAMASK - The Duesseldorf Advanced Material Simulation Kit
- pkgver = 3.0.0~alpha6
- pkgrel = 4
+ pkgver = 3.0.0~alpha7
+ pkgrel = 1
url = https://damask.mpie.de
arch = x86_64
license = AGPL3
@@ -18,10 +18,12 @@ pkgbase = damask
makedepends = python-h5py
makedepends = python-pyaml
optdepends = paraview: post-processing
- source = https://damask3.mpie.de/download/damask-3.0.0-alpha6.tar.xz
- source = 0001-PETSc-3.17.1-backport.patch
- sha256sums = de6748c285558dec8f730c4301bfa56b4078c130ff80e3095faf76202f8d2109
- sha256sums = d810807b097512c275ff43f66873117f54a190ab9cd2696c24f6c6cb1792ae1c
+ source = https://damask3.mpie.de/download/damask-3.0.0-alpha7.tar.xz
+ source = CMakeLists.patch
+ source = setup.patch
+ sha256sums = 442b06b824441293e72ff91b211a555c5d497aedf62be1c4332c426558b848a4
+ sha256sums = 296d2401fdbab78083a68366bfd0c9ac0ace096305ea9acbed0581d265be4f87
+ sha256sums = c98b009ac98952528d3d50a0844d433b8635206df3e0525a8018ad68c6fad947
pkgname = damask
depends = python-damask
diff --git a/0001-PETSc-3.17.1-backport.patch b/0001-PETSc-3.17.1-backport.patch
deleted file mode 100644
index 26bd9bcf66c6..000000000000
--- a/0001-PETSc-3.17.1-backport.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From bbf1d3253058e94300a79dfddec1453b36a8f940 Mon Sep 17 00:00:00 2001
-From: Martin Diehl <mail@martin-diehl.net>
-Date: Fri, 30 Sep 2022 13:27:32 +0200
-Subject: [PATCH] PETSc 3.17.1 backport
-
----
- CMakeLists.txt | 2 +-
- src/DAMASK_interface.f90 | 2 +-
- src/mesh/discretization_mesh.f90 | 4 ++++
- 3 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b4c405319..7a6f9ea7f 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -10,7 +10,7 @@ endif()
- # Dummy project to determine compiler names and version
- project(Prerequisites LANGUAGES)
- set(ENV{PKG_CONFIG_PATH} "$ENV{PETSC_DIR}/$ENV{PETSC_ARCH}/lib/pkgconfig")
--pkg_check_modules(PETSC REQUIRED PETSc>=3.12.0 PETSc<3.17.0)
-+pkg_check_modules(PETSC REQUIRED PETSc>=3.12.0 PETSc<3.18.0)
- pkg_get_variable(CMAKE_Fortran_COMPILER PETSc fcompiler)
- pkg_get_variable(CMAKE_C_COMPILER PETSc ccompiler)
-
-diff --git a/src/DAMASK_interface.f90 b/src/DAMASK_interface.f90
-index f5233f2f0..c37840a46 100644
---- a/src/DAMASK_interface.f90
-+++ b/src/DAMASK_interface.f90
-@@ -11,7 +11,7 @@
- !--------------------------------------------------------------------------------------------------
- #define PETSC_MAJOR 3
- #define PETSC_MINOR_MIN 12
--#define PETSC_MINOR_MAX 16
-+#define PETSC_MINOR_MAX 17
-
- module DAMASK_interface
- use, intrinsic :: ISO_fortran_env
-diff --git a/src/mesh/discretization_mesh.f90 b/src/mesh/discretization_mesh.f90
-index 9baff52fb..70ee28343 100644
---- a/src/mesh/discretization_mesh.f90
-+++ b/src/mesh/discretization_mesh.f90
-@@ -100,7 +100,11 @@ subroutine discretization_mesh_init(restart)
- debug_element = config_debug%get_asInt('element',defaultVal=1)
- debug_ip = config_debug%get_asInt('integrationpoint',defaultVal=1)
-
-+#if (PETSC_VERSION_MAJOR==3 && PETSC_VERSION_MINOR>16)
-+ call DMPlexCreateFromFile(PETSC_COMM_WORLD,interface_geomFile,'n/a',PETSC_TRUE,globalMesh,err_PETSc)
-+#else
- call DMPlexCreateFromFile(PETSC_COMM_WORLD,interface_geomFile,PETSC_TRUE,globalMesh,err_PETSc)
-+#endif
- CHKERRQ(err_PETSc)
- call DMGetDimension(globalMesh,dimPlex,err_PETSc)
- CHKERRQ(err_PETSc)
---
-2.37.3
-
diff --git a/CMakeLists.patch b/CMakeLists.patch
new file mode 100644
index 000000000000..2e701b372886
--- /dev/null
+++ b/CMakeLists.patch
@@ -0,0 +1,21 @@
+--- CMakeLists.txt.original 2022-10-10 11:15:50.430977247 +0200
++++ CMakeLists.txt.new 2022-10-10 11:26:53.792092659 +0200
+@@ -2,6 +2,9 @@
+ if(CMAKE_Fortran_COMPILER_ID STREQUAL "GNU")
+ # long lines for interaction matrix
+ set_source_files_properties("lattice.f90" PROPERTIES COMPILE_FLAGS "-ffree-line-length-240")
++ # CHKERRQ PETSc macro
++ set_source_files_properties("parallelization.f90" PROPERTIES COMPILE_FLAGS "-ffree-line-length-none")
++ set_source_files_properties("quit.f90" PROPERTIES COMPILE_FLAGS "-ffree-line-length-none")
+ endif()
+
+ file(GLOB damask-sources CONFIGURE_DEPENDS *.f90 *.c)
+@@ -18,7 +21,7 @@
+ file(READ ${solver-source} content)
+ string(FIND "${content}" "CHKERR" found)
+ if(NOT ${found} EQUAL -1)
+- set_source_files_properties(${solver-source} PROPERTIES COMPILE_FLAGS "-ffree-line-length-160")
++ set_source_files_properties(${solver-source} PROPERTIES COMPILE_FLAGS "-ffree-line-length-none")
+ endif()
+ endforeach()
+
diff --git a/PKGBUILD b/PKGBUILD
index 964508502eb9..b651ddf569df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Martin Diehl <martin.diehl@kuleuven.be>
pkgbase=damask
pkgname=('damask' 'damask-grid' 'damask-mesh' 'python-damask')
-pkgver=3.0.0~alpha6
-pkgver_=3.0.0-alpha6
-pkgrel=4
+pkgver=3.0.0~alpha7
+pkgver_=3.0.0-alpha7
+pkgrel=1
pkgdesc='DAMASK - The Duesseldorf Advanced Material Simulation Kit'
arch=('x86_64')
url='https://damask.mpie.de'
@@ -13,14 +13,16 @@ makedepends=('cmake' 'python-setuptools'
'python-matplotlib' 'python-scipy' 'python-pandas' 'python-h5py' 'python-pyaml')
optdepends=('paraview: post-processing')
source=(https://damask3.mpie.de/download/damask-${pkgver_}.tar.xz
- 0001-PETSc-3.17.1-backport.patch)
+ CMakeLists.patch
+ setup.patch)
-sha256sums=('de6748c285558dec8f730c4301bfa56b4078c130ff80e3095faf76202f8d2109'
- 'd810807b097512c275ff43f66873117f54a190ab9cd2696c24f6c6cb1792ae1c')
+sha256sums=('442b06b824441293e72ff91b211a555c5d497aedf62be1c4332c426558b848a4'
+ '296d2401fdbab78083a68366bfd0c9ac0ace096305ea9acbed0581d265be4f87'
+ 'c98b009ac98952528d3d50a0844d433b8635206df3e0525a8018ad68c6fad947')
prepare() {
- cd "$pkgname-$pkgver_"
- patch --forward --strip=1 --input="${srcdir}/0001-PETSc-3.17.1-backport.patch"
+ patch ${pkgname}-${pkgver_}/src/CMakeLists.txt "${srcdir}/CMakeLists.patch"
+ patch ${pkgname}-${pkgver_}/python/setup.cfg "${srcdir}/setup.patch"
}
build() {
@@ -31,8 +33,7 @@ build() {
cmake --build build-mesh
cd ${pkgbase}-${pkgver_}/python
- python setup.py build_ext --inplace
- python setup.py build
+ python -m build --wheel --no-isolation
}
package_damask-grid() {
@@ -68,8 +69,7 @@ package_python-damask() {
install -Dm644 ${pkgbase}-${pkgver_}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- cd ${pkgbase}-${pkgver_}/python
- python setup.py install --skip-build --root=${pkgdir} --optimize=1
+ python -m installer --destdir=${pkgdir} ${pkgbase}-${pkgver_}/python/dist/*.whl
}
package_damask() {
diff --git a/setup.patch b/setup.patch
new file mode 100644
index 000000000000..8aa93897c3de
--- /dev/null
+++ b/setup.patch
@@ -0,0 +1,11 @@
+--- setup.cfg.original 2022-10-10 11:34:22.934631052 +0200
++++ setup.cfg.new 2022-10-10 11:54:32.197194977 +0200
+@@ -6,7 +6,7 @@
+ url = https://damask.mpie.de
+ description = DAMASK processing tools
+ long_description = Pre- and post-processing tools for DAMASK
+-license: AGPL3
++license = AGPL3
+ classifiers =
+ Intended Audience :: Science/Research
+ Topic :: Scientific/Engineering