summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2023-11-14 18:02:58 +0100
committerMartin Diehl2023-11-14 18:02:58 +0100
commitcfae21cfcd3d1fd4abf2d21f94b7b6c60a022be8 (patch)
tree00961338876033f77848d254ba34e25ad5770e88
parent765bf6704d9db9d18c46810d43d255b432340331 (diff)
downloadaur-cfae21cfcd3d1fd4abf2d21f94b7b6c60a022be8.tar.gz
3.0.0~alpha8
-rw-r--r--.SRCINFO14
-rw-r--r--CMakeLists.patch21
-rw-r--r--PKGBUILD30
-rw-r--r--T-init.patch11
-rw-r--r--setup.patch11
5 files changed, 11 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2176a14dfca..9149eb9013a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = damask
pkgdesc = DAMASK - The Duesseldorf Advanced Material Simulation Kit
- pkgver = 3.0.0~alpha7
- pkgrel = 6
+ pkgver = 3.0.0~alpha8
+ pkgrel = 1
url = https://damask.mpie.de
arch = x86_64
license = AGPL3
@@ -18,14 +18,8 @@ pkgbase = damask
makedepends = python-h5py
makedepends = python-pyaml
optdepends = paraview: post-processing
- source = https://damask.mpie.de/download/damask-3.0.0-alpha7.tar.xz
- source = T-init.patch
- source = CMakeLists.patch
- source = setup.patch
- sha256sums = 442b06b824441293e72ff91b211a555c5d497aedf62be1c4332c426558b848a4
- sha256sums = 188a94f1d0486548acf1246531f92bca91806cf5b1a48eb33c67e9dc6297d602
- sha256sums = 296d2401fdbab78083a68366bfd0c9ac0ace096305ea9acbed0581d265be4f87
- sha256sums = c98b009ac98952528d3d50a0844d433b8635206df3e0525a8018ad68c6fad947
+ source = https://damask.mpie.de/download/damask-3.0.0-alpha8.tar.xz
+ sha256sums = f62c38123213d1c1fe2eb8910b0ffbdc1cac56273c2520f3b64a553363190b9d
pkgname = damask
depends = python-damask
diff --git a/CMakeLists.patch b/CMakeLists.patch
deleted file mode 100644
index 2e701b372886..000000000000
--- a/CMakeLists.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- CMakeLists.txt.original 2022-10-10 11:15:50.430977247 +0200
-+++ CMakeLists.txt.new 2022-10-10 11:26:53.792092659 +0200
-@@ -2,6 +2,9 @@
- if(CMAKE_Fortran_COMPILER_ID STREQUAL "GNU")
- # long lines for interaction matrix
- set_source_files_properties("lattice.f90" PROPERTIES COMPILE_FLAGS "-ffree-line-length-240")
-+ # CHKERRQ PETSc macro
-+ set_source_files_properties("parallelization.f90" PROPERTIES COMPILE_FLAGS "-ffree-line-length-none")
-+ set_source_files_properties("quit.f90" PROPERTIES COMPILE_FLAGS "-ffree-line-length-none")
- endif()
-
- file(GLOB damask-sources CONFIGURE_DEPENDS *.f90 *.c)
-@@ -18,7 +21,7 @@
- file(READ ${solver-source} content)
- string(FIND "${content}" "CHKERR" found)
- if(NOT ${found} EQUAL -1)
-- set_source_files_properties(${solver-source} PROPERTIES COMPILE_FLAGS "-ffree-line-length-160")
-+ set_source_files_properties(${solver-source} PROPERTIES COMPILE_FLAGS "-ffree-line-length-none")
- endif()
- endforeach()
-
diff --git a/PKGBUILD b/PKGBUILD
index e95f67efc1b0..3048da0248bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Martin Diehl <martin.diehl@kuleuven.be>
pkgbase=damask
pkgname=('damask' 'damask-grid' 'damask-mesh' 'python-damask')
-pkgver=3.0.0~alpha7
-pkgver_=3.0.0-alpha7
-pkgrel=6
+pkgver=3.0.0~alpha8
+pkgver_=3.0.0-alpha8
+pkgrel=1
pkgdesc='DAMASK - The Duesseldorf Advanced Material Simulation Kit'
arch=('x86_64')
url='https://damask.mpie.de'
@@ -12,26 +12,10 @@ makedepends=('cmake' 'python-setuptools'
'petsc<3.21' 'hdf5-openmpi' 'fftw' 'zlib' 'libfyaml'
'python-matplotlib' 'python-scipy' 'python-pandas' 'python-h5py' 'python-pyaml')
optdepends=('paraview: post-processing')
-source=(https://damask.mpie.de/download/damask-${pkgver_}.tar.xz
- T-init.patch
- CMakeLists.patch
- setup.patch)
-
-sha256sums=('442b06b824441293e72ff91b211a555c5d497aedf62be1c4332c426558b848a4'
- '188a94f1d0486548acf1246531f92bca91806cf5b1a48eb33c67e9dc6297d602'
- '296d2401fdbab78083a68366bfd0c9ac0ace096305ea9acbed0581d265be4f87'
- 'c98b009ac98952528d3d50a0844d433b8635206df3e0525a8018ad68c6fad947')
-
-prepare() {
- sed -i '24s/18/20/g' ${pkgname}-${pkgver_}/src/CLI.f90
- sed -i '14s/19/21/g' ${pkgname}-${pkgver_}/CMakeLists.txt
- sed -i '124s/${fYAML_LIBRARIES}/fyaml/g' ${pkgname}-${pkgver_}/CMakeLists.txt
- sed -i '73d;75d;77d' ${pkgname}-${pkgver_}/src/mesh/discretization_mesh.f90
- sed -i '92i DMAddField, &' ${pkgname}-${pkgver_}/src/mesh/mesh_mech_FEM.f90
- patch ${pkgname}-${pkgver_}/src/grid/grid_thermal_spectral.f90 "${srcdir}/T-init.patch"
- patch ${pkgname}-${pkgver_}/src/CMakeLists.txt "${srcdir}/CMakeLists.patch"
- patch ${pkgname}-${pkgver_}/python/setup.cfg "${srcdir}/setup.patch"
-}
+source=(https://damask.mpie.de/download/damask-${pkgver_}.tar.xz)
+
+sha256sums=('f62c38123213d1c1fe2eb8910b0ffbdc1cac56273c2520f3b64a553363190b9d')
+
build() {
cmake -S ${pkgbase}-${pkgver_} -B build-grid -DDAMASK_SOLVER=grid -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Performance
diff --git a/T-init.patch b/T-init.patch
deleted file mode 100644
index 197417c7a04e..000000000000
--- a/T-init.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- grid_thermal_spectral.f90.original 2023-06-17 00:35:03.454061742 +0200
-+++ grid_thermal_spectral.f90.new 2023-06-17 00:38:50.641104409 +0200
-@@ -110,7 +110,7 @@
- T_current = discretization_grid_getInitialCondition('T')
- T_lastInc = T_current
- T_stagInc = T_current
-- dotT_lastInc = 0.0_pReal
-+ dotT_lastInc = 0.0_pREAL * T_current
-
- !--------------------------------------------------------------------------------------------------
- ! initialize solver specific parts of PETSc
diff --git a/setup.patch b/setup.patch
deleted file mode 100644
index 8aa93897c3de..000000000000
--- a/setup.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.cfg.original 2022-10-10 11:34:22.934631052 +0200
-+++ setup.cfg.new 2022-10-10 11:54:32.197194977 +0200
-@@ -6,7 +6,7 @@
- url = https://damask.mpie.de
- description = DAMASK processing tools
- long_description = Pre- and post-processing tools for DAMASK
--license: AGPL3
-+license = AGPL3
- classifiers =
- Intended Audience :: Science/Research
- Topic :: Scientific/Engineering