summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwicast2015-06-08 20:49:31 +0800
committerwicast2015-06-08 20:49:31 +0800
commit0170b02b0e3690a473191f7f45865e97f97eccf1 (patch)
treef0a13a9df673c32186d774287965a63982654e3a
downloadaur-0170b02b0e3690a473191f7f45865e97f97eccf1.tar.gz
move 2 aur4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD45
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6579554b82b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = danmaku2ass-native
+ pkgdesc = Convert comments from bilibili to ASS format ( cpp version )
+ pkgver = b2def5f
+ pkgrel = 2
+ url = http://blog.eqoe.cn/posts/danmaku2ass_native.html
+ arch = i686
+ arch = x86_64
+ license = WTFPL
+ makedepends = git
+ makedepends = cmake
+ source = danmaku2ass-native::git://github.com/typcn/danmaku2ass_native.git
+ md5sums = SKIP
+ depends_x86_64 = gcc-libs-multilib
+
+pkgname = danmaku2ass-native
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e01352a2f6da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: wicast <wicastchen at hotmail.com>
+
+pkgname='danmaku2ass-native'
+pkgver=b2def5f
+pkgrel=2
+epoch=
+pkgdesc="Convert comments from bilibili to ASS format ( cpp version )"
+arch=('i686' 'x86_64')
+url="http://blog.eqoe.cn/posts/danmaku2ass_native.html"
+license=('WTFPL')
+groups=()
+depends=('')
+depends_x86_64=('gcc-libs-multilib')
+makedepends=('git' 'cmake')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname::git://github.com/typcn/danmaku2ass_native.git")
+noextract=()
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+build() {
+ cd "$srcdir/$pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" .
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm=775 danmaku2ass_native "${pkgdir}/usr/bin/danmaku2ass-native"
+ install -Dm=775 libdanmaku2ass.so "${pkgdir}/usr/lib/libdanmaku2ass.so"
+ install -Dm=775 danmaku2ass.h "${pkgdir}/usr/include/danmaku2ass.h"
+}