summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Pacner2015-06-26 17:31:23 +0200
committerJan Pacner2015-06-26 17:31:23 +0200
commite786fc2ff89ce0e937aa8da89f032e16d3fba298 (patch)
treeb775ba16113a6ba386278fb472d68b46ce67b478
parentbb14a8fd9854c01889f31666b6979682145a47c5 (diff)
downloadaur-e786fc2ff89ce0e937aa8da89f032e16d3fba298.tar.gz
change: version bump
remove: web.html module (temporarily can not compile
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc1f875e8c37..d105ed283ca4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_basename=dao
pkgname=${_basename}-git
-pkgver=1496.988e4c4
+pkgver=1501.b74129b
pkgrel=1
pkgdesc='A very lightweight, portable, optionally typed programming language and VM written in C featuring blazingly fast real concurrency, defer, OOP, AOP, LLVM JIT, bytecode, BNF macros, many advanced modules & bindings and much more!'
url='http://www.daovm.net/'
@@ -114,6 +114,8 @@ build() {
# wrap/dao_sdl.h:18:16: fatal error: SDL.h: No such file or directory
# #include"SDL.h"
#mv "DaoSDL/" "$_basename/modules/"
+ # FIXME https://github.com/daokoder/dao/issues/418
+ rm -rf "$_basename/modules/web/html/"
cd "$_basename"
# order matters when using gcc
@@ -158,9 +160,6 @@ EOF
#sed -i -r '/regex/s|^[ #]+||' modules/makefile.dao
sed -i -r '/regex/s|(.*)|#\1|' modules/makefile.dao
- # FIXME will be fixed in upstream soon
- sed -i -r '/image/s|(.*)|#\1|' modules/makefile.dao
-
# https://github.com/daokoder/DaoSDL/issues/2
#sed -i -r 's|(#include) *"(SDL[^"]+)"|\1 <SDL2/\2>|' \
# modules/DaoSDL/wrap/dao_sdl.h