summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-06-13 15:32:42 +0200
committerMarco Pompili2015-06-13 15:32:42 +0200
commit068df33fc0b2558e029cc84b54fc0eecde45cc84 (patch)
treec0fbd298ffe41cb54ff76424b5deb51c0bd1103d
downloadaur-068df33fc0b2558e029cc84b54fc0eecde45cc84.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
-rwxr-xr-xdaphne.sh17
-rw-r--r--roms.tar.gzbin0 -> 12858 bytes
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c2b12f68d2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = daphne
+ pkgdesc = A command-line multiple arcade laserdisc emulator.
+ pkgver = 1.0
+ pkgrel = 2
+ url = http://www.daphne-emu.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glew
+ depends = sdl_mixer
+ depends = zlib
+ depends = gcc-libs
+ depends = libxmu
+ source = http://www.daphne-emu.com/download/daphne-1.0beta-linux.tar.gz
+ source = daphne.sh
+ source = roms.tar.gz
+ md5sums = a7812a93bc19fe9ec4cd0a1a7066c71f
+ md5sums = 3db2aff0763ec628d10e0cc09a27e2f5
+ md5sums = 4f42811b7f71b1d0f23422ad2894f25d
+
+pkgname = daphne
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c8ef08e37f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Marco Pompili (emarcs) <marcs.pompili@gmail.com>
+# Maintainer: Marco Pompili (emarcs) <marcs.pompili@gmail.com>
+
+pkgname=daphne
+pkgver=1.0
+pkgrel=2
+pkgdesc="A command-line multiple arcade laserdisc emulator."
+url="http://www.daphne-emu.com/"
+license="GPL"
+arch=('i686' 'x86_64')
+if [ "$CARCH" = "x86_64" ]; then
+ depends=('lib32-glew' 'lib32-sdl_mixer' 'lib32-zlib' 'lib32-gcc-libs' 'lib32-libxmu')
+ else
+ depends=('glew' 'sdl_mixer' 'zlib' 'gcc-libs' 'libxmu')
+ fi
+source=("http://www.daphne-emu.com/download/${pkgname}-${pkgver}beta-linux.tar.gz" \
+ daphne.sh \
+ roms.tar.gz)
+md5sums=('a7812a93bc19fe9ec4cd0a1a7066c71f' '3db2aff0763ec628d10e0cc09a27e2f5'\
+ '4f42811b7f71b1d0f23422ad2894f25d')
+
+package()
+{
+ # Install everything in /usr/share
+ cd ${startdir}/src/${pkgname}
+ install -Dm755 ${startdir}/src/daphne.sh ${startdir}/pkg/usr/bin/${pkgname}
+ install -Dm755 ${pkgname} ${startdir}/pkg/usr/share/${pkgname}/${pkgname}
+ install -m644 libvldp2.so ${startdir}/pkg/usr/share/${pkgname}/libvldp2.so
+ mkdir ${startdir}/pkg/usr/lib
+ install -m644 ${startdir}/src/${pkgname}/lib/libGLEW.so.1.3 ${startdir}/pkg/usr/lib/
+ install -d ${startdir}/pkg/usr/share/${pkgname}/{images,pics,roms/cputest,sound}
+ install -m644 images/*.jpg ${startdir}/pkg/usr/share/${pkgname}/images/
+ install -m644 pics/* ${startdir}/pkg/usr/share/${pkgname}/pics/
+ install -m644 ${startdir}/src/roms/cputest/* ${startdir}/pkg/usr/share/${pkgname}/roms/cputest/
+ install -m644 sound/* ${startdir}/pkg/usr/share/${pkgname}/sound/
+}
diff --git a/daphne.sh b/daphne.sh
new file mode 100755
index 000000000000..e7d3d7131d29
--- /dev/null
+++ b/daphne.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+if [ ! -e $HOME/.daphne ]; then
+ echo "Running Daphne for the first time..."
+ echo "Copy your framefiles/roms/mpegs to the corresponding folders"
+ echo "within $HOME/.daphne and reference them from the command-line."
+ echo "Ex: daphne lair vldp -framefile '~/.daphne/framefile/lair.txt'"
+ mkdir $HOME/.daphne
+ mkdir $HOME/.daphne/{roms,mpegs}
+ cp -R /usr/share/daphne/roms/* $HOME/.daphne/roms/
+ cd /usr/share/daphne
+ ./daphne "$@"
+else
+ export PATH=/usr/share/daphne:$PATH
+ cd /usr/share/daphne
+ ./daphne "$@"
+fi
diff --git a/roms.tar.gz b/roms.tar.gz
new file mode 100644
index 000000000000..c46e6c855578
--- /dev/null
+++ b/roms.tar.gz
Binary files differ