summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWinston Wu2019-02-15 19:40:07 -0500
committerWinston Wu2019-02-15 19:40:07 -0500
commit6db8a1e1d98cfb07e0fa0ed608fb938f0cc4b860 (patch)
tree846def55e0bacc371333d808c15d9b7f77d82a9d
downloadaur-6db8a1e1d98cfb07e0fa0ed608fb938f0cc4b860.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD49
-rwxr-xr-xdaphne.sh60
-rwxr-xr-xsinge.sh51
4 files changed, 187 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd65a154eee4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat Feb 16 00:39:49 UTC 2019
+pkgbase = daphne-git
+ pkgdesc = A command-line multiple arcade laserdisc emulator. GIT fork
+ pkgver = 100.0e76a0d
+ pkgrel = 1
+ url = http://www.daphne-emu.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glew
+ depends = sdl_mixer
+ depends = zlib
+ depends = gcc-libs
+ depends = libxmu
+ provides = daphne
+ conflicts = daphne
+ source = git://github.com/DavidGriffith/daphne.git
+ source = daphne.sh
+ source = singe.sh
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = daphne-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a834be5a45e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: Marco Pompili (emarcs) <marcs.pompili@gmail.com>
+# Maintainer: Marco Pompili (emarcs) <marcs.pompili@gmail.com>
+
+pkgname=daphne-git
+_pkgname=daphne
+pkgver=100.0e76a0d
+pkgrel=1
+pkgdesc="A command-line multiple arcade laserdisc emulator. GIT fork"
+url="http://www.daphne-emu.com/"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('glew' 'sdl_mixer' 'zlib' 'gcc-libs' 'libxmu')
+makedepends=('git')
+provides=('daphne')
+conflicts=('daphne')
+source=('git://github.com/DavidGriffith/daphne.git' 'daphne.sh' 'singe.sh')
+sha256sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver()
+{
+ cd ${srcdir}/${_pkgname}
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build()
+{
+ cd ${srcdir}/${_pkgname}
+ cd src/vldp2
+ ./configure --disable-accel-detect
+ make -f Makefile.linux_x64
+ cd ..
+ ln -s Makefile.vars.linux_x64 Makefile.vars
+ make
+ cd ..
+}
+
+package()
+{
+ # Install everything in /usr/share
+ cd ${srcdir}/${_pkgname}
+ install -Dm755 ${srcdir}/daphne.sh ${pkgdir}/usr/bin/daphne
+ install -Dm755 ${srcdir}/singe.sh ${pkgdir}/usr/bin/singe
+ install -Dm755 ${_pkgname}.bin ${pkgdir}/usr/share/${_pkgname}/${_pkgname}
+ install -d ${pkgdir}/usr/share/${_pkgname}/{pics,pics/obsolete,roms/cputest,sound}
+ install -m644 pics/*.* ${pkgdir}/usr/share/${_pkgname}/pics/
+ install -m644 pics/obsolete/*.* ${pkgdir}/usr/share/${_pkgname}/pics/obsolete/
+ install -m644 roms/cputest/* ${pkgdir}/usr/share/${_pkgname}/roms/cputest/
+ install -m644 sound/* ${pkgdir}/usr/share/${_pkgname}/sound/
+}
diff --git a/daphne.sh b/daphne.sh
new file mode 100755
index 000000000000..dd8eb24aba82
--- /dev/null
+++ b/daphne.sh
@@ -0,0 +1,60 @@
+#!/bin/sh
+
+SCRIPT_DIR=`dirname "$0"`
+if realpath / >/dev/null; then SCRIPT_DIR=$(realpath "$SCRIPT_DIR"); fi
+DAPHNE_BIN=/usr/share/daphne.bin
+DAPHNE_SHARE=~/.daphne
+DAPHNE_DATA=/usr/share/daphne
+
+echo "Daphne Launcher : Script dir is $SCRIPT_DIR"
+cd "$SCRIPT_DIR"
+
+# point to our linked libs that user may not have
+export LD_LIBRARY_PATH=$SCRIPT_DIR:$DAPHNE_SHARE:$LD_LIBRARY_PATH
+
+if [ -z $1 ] ; then
+ echo "Specify a game to try: ace astron badlands bega cliff cobra esh"
+ echo "\tgalaxyr gpworld interstellar lair lair2 mach3 rb sdq tq uvt"
+ exit
+fi
+
+case "$1" in
+ lair|lair2|ace|tq)
+ VLDP_DIR="vldp_dl"
+ FASTBOOT="-fastboot"
+ ;;
+ *) VLDP_DIR="vldp"
+esac
+
+#strace -o strace.txt \
+./$DAPHNE_BIN $1 vldp \
+$FASTBOOT \
+-framefile $DAPHNE_SHARE/$VLDP_DIR/$1/$1.txt \
+-homedir $DAPHNE_SHARE \
+-datadir $DAPHNE_DATA \
+-blank_searches \
+-min_seek_delay 1000 \
+-seek_frames_per_ms 20 \
+-sound_buffer 2048 \
+-noserversend \
+-x 640 \
+-y 480
+
+#-bank 0 11111001 \
+#-bank 1 00100111 \
+
+EXIT_CODE=$?
+
+if [ "$EXIT_CODE" -ne "0" ] ; then
+ if [ "$EXIT_CODE" -eq "127" ]; then
+ echo ""
+ echo "Daphne failed to start."
+ echo "This is probably due to a library problem."
+ echo "Run ./daphne.bin directly to see which libraries are missing."
+ echo ""
+ else
+ echo "DaphneLoader failed with an unknown exit code : $EXIT_CODE."
+ fi
+fi
+
+
diff --git a/singe.sh b/singe.sh
new file mode 100755
index 000000000000..7e9f7a785c6d
--- /dev/null
+++ b/singe.sh
@@ -0,0 +1,51 @@
+#!/bin/sh
+
+SCRIPT_DIR=`dirname "$0"`
+DAPHNE_BIN=/usr/share/daphne.bin
+DAPHNE_SHARE=~/.daphne
+DAPHNE_DATA=/usr/share/daphne
+
+echo "Singe Launcher : Script dir is $SCRIPT_DIR"
+cd "$SCRIPT_DIR"
+
+# point to our linked libs that user may not have
+LD_LIBRARY_PATH=$PWD:$LD_LIBRARY_PATH
+
+if [ -z $1 ] ; then
+ echo "Specify a game to try: timegal"
+ exit
+fi
+
+
+#strace -o strace.txt \
+./$DAPHNE_BIN singe vldp \
+-framefile $DAPHNE_SHARE/singe/$1/$1.txt \
+-script $DAPHNE_SHARE/singe/$1/$1.singe \
+-homedir $DAPHNE_SHARE \
+-datadir $DAPHNE_DATA \
+-blank_searches \
+-min_seek_delay 1000 \
+-seek_frames_per_ms 20 \
+-sound_buffer 2048 \
+-noserversend \
+-x 640 \
+-y 480
+
+#-bank 0 11111001 \
+#-bank 1 00100111 \
+
+EXIT_CODE=$?
+
+if [ "$EXIT_CODE" -ne "0" ] ; then
+ if [ "$EXIT_CODE" -eq "127" ]; then
+ echo ""
+ echo "Daphne failed to start."
+ echo "This is probably due to a library problem."
+ echo "Run ./daphne.bin directly to see which libraries are missing."
+ echo ""
+ else
+ echo "DaphneLoader failed with an unknown exit code : $EXIT_CODE."
+ fi
+fi
+
+