summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Harvey2015-07-17 21:43:10 +0000
committerJames Harvey2015-07-17 21:43:10 +0000
commit686ef121c1328ea035f42dcf24c8d76e3201ed83 (patch)
tree2d22fdbc1abc82804ec5215a7a191b2930dad2d6
downloadaur-686ef121c1328ea035f42dcf24c8d76e3201ed83.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85a8e8513ad3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dapl
+ pkgdesc = OpenFabrics Alliance direct access transport libraries for InfiniBand
+ pkgver = 2.1.5
+ pkgrel = 1
+ url = https://www.openfabrics.org/downloads/dapl/README.html
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ license = custom:"Open Fabrics Alliance BSD"
+ depends = librdmacm
+ source = https://www.openfabrics.org/downloads/dapl/dapl-2.1.5.tar.gz
+ md5sums = 8a7735bfe24dd7c446aec38db3577728
+
+pkgname = dapl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6a75b6b1ec6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: James Harvey <jamespharvey20@gmail.com>
+# * No namcap warnings or errors
+
+pkgname=dapl
+pkgver=2.1.5
+pkgrel=1
+pkgdesc='OpenFabrics Alliance direct access transport libraries for InfiniBand'
+arch=('x86_64' 'i686')
+url=('https://www.openfabrics.org/downloads/dapl/README.html')
+license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
+depends=('librdmacm')
+source=("https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('8a7735bfe24dd7c446aec38db3577728')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}