summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Knopf2018-11-03 11:41:04 -0400
committerPaul Knopf2018-11-03 11:41:04 -0400
commitda96dbfda6dd0a8fe339244560cd7a8a36499437 (patch)
tree14540868e6ea2e5ffbc8a27a9251c48d4d9a9f6b
parenteceaa6a9dbb0806865b3da3b7ad2aec363633d52 (diff)
downloadaur-da96dbfda6dd0a8fe339244560cd7a8a36499437.tar.gz
Auto update from to 0.25.0.
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD14
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0445f6dc35a3..c5947a7b89da 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = darch
pkgdesc = A utility to that uses containerd to build stateless operating system images that can be booted bare-metal.
pkgver = 0.25.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/godarch/darch
arch = x86_64
license = MIT
- depends = libseccomp,
+ makedepends = go
depends = containerd
source = darch-0.25.0.tar.gz::https://github.com/godarch/darch/archive/v0.25.0.tar.gz
md5sums = 79e8f497d8e761e15245290b040a4dcc
diff --git a/PKGBUILD b/PKGBUILD
index 146dc3ce4796..0a1f94a17870 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Paul Knopf <pauldotknopf@gmail.com>
pkgname=darch
pkgver=0.25.0
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="A utility to that uses containerd to build stateless operating system images that can be booted bare-metal."
arch=('x86_64')
url="https://github.com/godarch/darch"
license=('MIT')
groups=()
-depends=('libseccomp', 'containerd')
-makedepends=()
+depends=('containerd')
+makedepends=('go')
checkdepends=()
optdepends=()
replaces=()
@@ -21,7 +21,13 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/godarch/darch/archive/v$pkg
md5sums=('79e8f497d8e761e15245290b040a4dcc')
noextract=()
validpgpkeys=()
+build() {
+ export GOPATH="$srcdir/.gopath"
+ mkdir -p "$GOPATH/src/github.com/godarch"
+ ln -s "$srcdir/$pkgname-$pkgver" "$GOPATH/src/github.com/godarch/darch"
+ cd "$GOPATH/src/github.com/godarch/darch" && make
+}
package() {
# The tarball has all the directories setup correctly.
- make install DESTDIR=$pkgdir
+ cd "$GOPATH/src/github.com/godarch/darch" && make install DESTDIR=$pkgdir
}