summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirtualTam2017-10-14 11:56:23 +0200
committerVirtualTam2017-10-14 11:56:23 +0200
commit74db27b3e0e0c2fea99ccd14ff486d2d3cf3faca (patch)
tree5b19cfbb6f9dc9bb244ac463ba450d616e4b1aef
parent94152d660cccb25793cb67eed6672b5843d9bb1a (diff)
downloadaur-74db27b3e0e0c2fea99ccd14ff486d2d3cf3faca.tar.gz
darkaudacity: switch tu upstream repository
Signed-off-by: VirtualTam <virtualtam@flibidi.net>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--audacity-ffmpeg.patch30
3 files changed, 8 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ea308cb822b..ee1161c5741d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Wed Dec 28 15:58:42 UTC 2016
+# Sat Oct 14 09:55:51 UTC 2017
pkgbase = darkaudacity-git
pkgdesc = A program that lets you manipulate digital audio waveforms
- pkgver = 2.1.3x.r221.g17aa9a93
+ pkgver = 2.1.3.r1237.gec4838600
pkgrel = 1
- url = http://www.darkaudacity.com/
+ url = http://wiki.audacityteam.org/wiki/DarkAudacity
arch = i686
arch = x86_64
license = GPL
@@ -24,10 +24,8 @@ pkgbase = darkaudacity-git
provides = audacity
conflicts = audacity
options = !makeflags
- source = git://github.com/JamesCrook/audacity.git#branch=darkaudacity
- source = audacity-ffmpeg.patch
+ source = git://github.com/audacity/audacity.git#branch=darkaudacity
sha1sums = SKIP
- sha1sums = 5f1733a3802bcec7d9b54cb3ec8d7d81fc38fc61
pkgname = darkaudacity-git
diff --git a/PKGBUILD b/PKGBUILD
index 05a8011a5a68..b6fa5def328b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@
# Contributor: Eric BĂ©langer <eric@archlinux.org>
pkgname=darkaudacity-git
_gitname=audacity
-pkgver=2.1.3x.r221.g17aa9a93
+pkgver=2.1.3.r1237.gec4838600
pkgrel=1
pkgdesc="A program that lets you manipulate digital audio waveforms"
arch=('i686' 'x86_64')
-url="http://www.darkaudacity.com/"
+url="http://wiki.audacityteam.org/wiki/DarkAudacity"
license=('GPL')
depends=('libmad' 'libid3tag' 'libsoxr' 'lilv' 'portsmf' 'soundtouch'
'suil' 'twolame' 'vamp-plugin-sdk' 'wxgtk')
@@ -17,21 +17,14 @@ makedepends=('cmake' 'git' 'python2')
options=('!makeflags')
provides=('audacity')
conflicts=('audacity')
-source=(git://github.com/JamesCrook/${_gitname}.git#branch=darkaudacity
- audacity-ffmpeg.patch)
-sha1sums=(SKIP
- 5f1733a3802bcec7d9b54cb3ec8d7d81fc38fc61)
+source=(git://github.com/audacity/${_gitname}.git#branch=darkaudacity)
+sha1sums=(SKIP)
pkgver() {
cd ${_gitname}
git describe --tags | sed 's/^\(Dark\)\?Audacity.//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd ${_gitname}
- patch -p1 -i ${srcdir}/audacity-ffmpeg.patch
-}
-
build() {
cd ${_gitname}
./configure --prefix=/usr --with-libsamplerate
diff --git a/audacity-ffmpeg.patch b/audacity-ffmpeg.patch
deleted file mode 100644
index d0b9935d3e15..000000000000
--- a/audacity-ffmpeg.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -Naur audacity-src-2.0.6-orig/src/FFmpeg.h audacity-src-2.0.6/src/FFmpeg.h
---- audacity-src-2.0.6-orig/src/FFmpeg.h 2014-09-28 21:54:55.159636208 -0400
-+++ audacity-src-2.0.6/src/FFmpeg.h 2014-09-28 21:55:11.246276766 -0400
-@@ -688,7 +688,7 @@
- FFMPEG_FUNCTION_WITH_RETURN(
- AVOutputFormat*,
- av_oformat_next,
-- (AVOutputFormat *f),
-+ (const AVOutputFormat *f),
- (f)
- );
- FFMPEG_FUNCTION_WITH_RETURN(
-@@ -755,7 +755,7 @@
- FFMPEG_FUNCTION_WITH_RETURN(
- int,
- av_fifo_size,
-- (AVFifoBuffer *f),
-+ (const AVFifoBuffer *f),
- (f)
- );
- FFMPEG_FUNCTION_WITH_RETURN(
-@@ -801,7 +801,7 @@
- FFMPEG_FUNCTION_WITH_RETURN(
- AVDictionaryEntry *,
- av_dict_get,
-- (AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
-+ (const AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
- (m, key, prev, flags)
- );
- FFMPEG_FUNCTION_WITH_RETURN(