summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirtualTam2016-08-30 22:05:43 +0200
committerVirtualTam2016-08-30 22:05:43 +0200
commitf9b5fc9aceb910a83f4e208645a54b875f0fe038 (patch)
treec5e251d9cd1d2fa1d6a21ec51b394f1ed96914f1
downloadaur-f9b5fc9aceb910a83f4e208645a54b875f0fe038.tar.gz
darkaudacity: initial PKGBUILD
See: - http://www.darkaudacity.com/ - http://www.darkaudacity.com/download.html Signed-off-by: VirtualTam <virtualtam@flibidi.net>
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
-rw-r--r--audacity-ffmpeg.patch30
-rw-r--r--darkaudacity.install13
5 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e7c1967361c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+# Generated by mksrcinfo v8
+# Tue Aug 30 20:04:41 UTC 2016
+pkgbase = darkaudacity-git
+ pkgdesc = A program that lets you manipulate digital audio waveforms
+ pkgver = 2.1.2.r1445.g9e41323
+ pkgrel = 1
+ url = http://www.darkaudacity.com/
+ install = darkaudacity.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ makedepends = python2
+ makedepends = twolame
+ depends = ffmpeg
+ depends = desktop-file-utils
+ depends = lame
+ depends = libmad
+ depends = libid3tag
+ depends = lilv
+ depends = portsmf
+ depends = soundtouch
+ depends = sbsms
+ depends = vamp-plugin-sdk
+ depends = webkitgtk2
+ depends = wxgtk
+ provides = audacity
+ conflicts = audacity
+ options = !makeflags
+ source = git://github.com/JamesCrook/audacity.git#branch=darkaudacity
+ source = audacity-ffmpeg.patch
+ sha1sums = SKIP
+ sha1sums = 5f1733a3802bcec7d9b54cb3ec8d7d81fc38fc61
+
+pkgname = darkaudacity-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..64573269b6b3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+audacity/
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96011cfeb1cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: VirtualTam <virtualtam@flibidi.net>
+#
+# Based upon https://aur.archlinux.org/packages/audacity-git/
+# Contributor: Proudzhu <proudzhu.fdu at gmail.com>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+pkgname=darkaudacity-git
+_gitname=audacity
+pkgver=2.1.2.r1445.g9e41323
+pkgrel=1
+pkgdesc="A program that lets you manipulate digital audio waveforms"
+arch=('i686' 'x86_64')
+url="http://www.darkaudacity.com/"
+license=('GPL')
+depends=('ffmpeg' 'desktop-file-utils' 'lame' 'libmad' 'libid3tag' 'lilv'
+ 'portsmf' 'soundtouch' 'sbsms' 'vamp-plugin-sdk'
+ 'webkitgtk2' 'wxgtk')
+makedepends=('cmake' 'git' 'python2' 'twolame')
+options=('!makeflags')
+install=darkaudacity.install
+provides=('audacity')
+conflicts=('audacity')
+source=(git://github.com/JamesCrook/${_gitname}.git#branch=darkaudacity
+ audacity-ffmpeg.patch)
+sha1sums=(SKIP
+ 5f1733a3802bcec7d9b54cb3ec8d7d81fc38fc61)
+
+pkgver() {
+ cd ${_gitname}
+ git describe --tags | sed 's/^Audacity.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd ${_gitname}
+ patch -p1 -i ${srcdir}/audacity-ffmpeg.patch
+}
+
+build() {
+ cd ${_gitname}
+ ./configure --prefix=/usr --with-libsamplerate
+ make
+}
+
+package() {
+ cd ${_gitname}
+ make DESTDIR=${pkgdir} install
+}
diff --git a/audacity-ffmpeg.patch b/audacity-ffmpeg.patch
new file mode 100644
index 000000000000..d0b9935d3e15
--- /dev/null
+++ b/audacity-ffmpeg.patch
@@ -0,0 +1,30 @@
+diff -Naur audacity-src-2.0.6-orig/src/FFmpeg.h audacity-src-2.0.6/src/FFmpeg.h
+--- audacity-src-2.0.6-orig/src/FFmpeg.h 2014-09-28 21:54:55.159636208 -0400
++++ audacity-src-2.0.6/src/FFmpeg.h 2014-09-28 21:55:11.246276766 -0400
+@@ -688,7 +688,7 @@
+ FFMPEG_FUNCTION_WITH_RETURN(
+ AVOutputFormat*,
+ av_oformat_next,
+- (AVOutputFormat *f),
++ (const AVOutputFormat *f),
+ (f)
+ );
+ FFMPEG_FUNCTION_WITH_RETURN(
+@@ -755,7 +755,7 @@
+ FFMPEG_FUNCTION_WITH_RETURN(
+ int,
+ av_fifo_size,
+- (AVFifoBuffer *f),
++ (const AVFifoBuffer *f),
+ (f)
+ );
+ FFMPEG_FUNCTION_WITH_RETURN(
+@@ -801,7 +801,7 @@
+ FFMPEG_FUNCTION_WITH_RETURN(
+ AVDictionaryEntry *,
+ av_dict_get,
+- (AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
++ (const AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
+ (m, key, prev, flags)
+ );
+ FFMPEG_FUNCTION_WITH_RETURN(
diff --git a/darkaudacity.install b/darkaudacity.install
new file mode 100644
index 000000000000..34ab919aaf96
--- /dev/null
+++ b/darkaudacity.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ update-mime-database usr/share/mime &> /dev/null
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}