summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-06-28 20:15:28 +0300
committerIgor Dyatlov2022-06-28 20:15:28 +0300
commit640fc0acbc93fb9758b9b66ffd4a393c2ce7cde2 (patch)
treed815506533eaccc998a0b70c0988a2be182e0769
downloadaur-640fc0acbc93fb9758b9b66ffd4a393c2ce7cde2.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb34ca8b34f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = darkbar-git
+ pkgdesc = Darken application titlebars based on your preference
+ pkgver = 1.0.1.r4.g304b282
+ pkgrel = 1
+ url = https://github.com/bluesabre/darkbar
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = libhandy
+ depends = libwnck3
+ depends = libgee
+ source = git+https://github.com/bluesabre/darkbar.git
+ b2sums = SKIP
+
+pkgname = darkbar-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..809706a164a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=darkbar-git
+pkgver=1.0.1.r4.g304b282
+pkgrel=1
+pkgdesc="Darken application titlebars based on your preference"
+arch=('x86_64' 'aarch64')
+url="https://github.com/bluesabre/darkbar"
+license=('GPL3')
+depends=('libhandy' 'libwnck3' 'libgee')
+makedepends=('git' 'meson' 'vala')
+source=(git+$url.git)
+b2sums=('SKIP')
+
+
+pkgver() {
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build || :
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}