summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2022-11-13 14:07:10 +0000
committerChristopher Arndt2022-11-13 14:07:10 +0000
commit56445f20eb3405788e9134d3cda1c9db00955018 (patch)
tree853744f667a4fa7d7de9cdc2b320bca570d619da
parentb41ce51e0f899285e0c1cb08da21bdb53b783b32 (diff)
downloadaur-darkice.tar.gz
feat: import package 'darkice' from AUR (#153)
-rw-r--r--.SRCINFO46
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
-rw-r--r--darkice@.service11
-rw-r--r--service10
5 files changed, 63 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69d577f5cb5a..a05c1a04fba9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,40 @@
pkgbase = darkice
- pkgdesc = Live audio streamer. Reads from audio interface, encodes, sends to streaming server.
+ pkgdesc = Reads live audio from backends, encodes it and streams it to a server
pkgver = 1.4
- pkgrel = 2
+ pkgrel = 3
url = http://www.darkice.org/
- arch = i686
- arch = x86_64
+ arch = aarch64
arch = armv6h
arch = armv7h
- license = GPL
- depends = lame
- depends = libpulse
- depends = faac
- depends = jack
- depends = twolame
- depends = opus
- depends = libsamplerate
- depends = fftw
+ arch = x86_64
+ license = GPL3
+ makedepends = alsa-lib
+ makedepends = faac
+ makedepends = flac
+ makedepends = jack
+ makedepends = lame
+ makedepends = libpulse
+ makedepends = libsamplerate
+ makedepends = libvorbis
+ makedepends = twolame
+ makedepends = opus
+ depends = gcc-libs
source = https://github.com/rafael2k/darkice/releases/download/v1.4/darkice-1.4.tar.gz
- source = service
+ source = darkice@.service
sha256sums = e6a8ec2b447cf5b4ffaf9b62700502b6bdacebf00b476f4e9bf9f9fe1e3dd817
- sha256sums = c5d05b1c3c352eda9591064f041fcd502d3b0a4cfcc6319dc4ae9b6d71136e4b
+ sha256sums = 7c65f92c885ed7e141d3289fd8e108dc3d7c19d5c4b3f948e7ce3ad6c653cd12
pkgname = darkice
+ depends = gcc-libs
+ depends = libmp3lame.so
+ depends = libogg.so
+ depends = libvorbis.so
+ depends = libvorbisenc.so
+ depends = libopus.so
+ depends = libfaac.so
+ depends = libtwolame.so
+ depends = libasound.so
+ depends = libpulse-simple.so
+ depends = libpulse.so
+ depends = libjack.so
+ depends = libsamplerate.so
diff --git a/.gitignore b/.gitignore
index ce1e2536a851..57e7fd90984f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
pkg/
src/
-darkice-*.pkg.tar.xz
-darkice-*.pkg.tar.zst
-darkice-*.tar.gz
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 78f654ec7d41..7dd67095db33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot de>
+# Maintainer: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot de>
# Contributor: Sam Mulvey <archlinux at sammulvey.com>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Ganjolinux aka Basalari David <ganjolinux@gmail.com>
@@ -7,20 +8,21 @@
pkgname=darkice
pkgver=1.4
-pkgrel=2
-pkgdesc="Live audio streamer. Reads from audio interface, encodes, sends to streaming server."
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-url="http://www.darkice.org/"
-license=('GPL')
-depends=('lame' 'libpulse' 'faac' 'jack' 'twolame' 'opus' 'libsamplerate' 'fftw')
-source=("https://github.com/rafael2k/darkice/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
- 'service')
+pkgrel=3
+pkgdesc='Reads live audio from backends, encodes it and streams it to a server'
+arch=(aarch64 armv6h armv7h x86_64)
+url='http://www.darkice.org/'
+license=(GPL3)
+depends=(gcc-libs)
+makedepends=(alsa-lib faac flac jack lame libpulse libsamplerate libvorbis twolame opus)
+source=("https://github.com/rafael2k/darkice/releases/download/v${pkgver}/$pkgname-$pkgver.tar.gz"
+ 'darkice@.service')
sha256sums=('e6a8ec2b447cf5b4ffaf9b62700502b6bdacebf00b476f4e9bf9f9fe1e3dd817'
- 'c5d05b1c3c352eda9591064f041fcd502d3b0a4cfcc6319dc4ae9b6d71136e4b')
+ '7c65f92c885ed7e141d3289fd8e108dc3d7c19d5c4b3f948e7ce3ad6c653cd12')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
export CXXFLAGS="$CXXFLAGS -std=c++11"
./configure \
@@ -39,12 +41,11 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- make DESTDIR="$pkgdir/" install
+ depends+=(libmp3lame.so libogg.so libvorbis.so libvorbisenc.so libopus.so
+ libfaac.so libtwolame.so libasound.so libpulse-simple.so
+ libpulse.so libjack.so libsamplerate.so)
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
# systemd service
- install -Dm644 "$srcdir/service" "$pkgdir/usr/lib/systemd/system/darkice@.service"
- # configuration
- install -dm755 "$pkgdir/etc/darkice"
- mv "$pkgdir/etc/darkice.cfg" "$pkgdir/etc/darkice"
+ install -Dm644 "$srcdir"/darkice@.service -t "$pkgdir"/usr/lib/systemd/user
}
diff --git a/darkice@.service b/darkice@.service
new file mode 100644
index 000000000000..e9b475d103e8
--- /dev/null
+++ b/darkice@.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=DarkIce Live Stream %i
+Documentation=man:darkice(1)
+After=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/darkice -c %h/.config/darkice/%i.conf
+
+[Install]
+WantedBy=default.target
diff --git a/service b/service
deleted file mode 100644
index 5bb64d7d4062..000000000000
--- a/service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=DarkIce Live Stream %i
-After=network.target
-
-[Service]
-Type=simple
-ExecStart=/usr/bin/darkice -c /etc/darkice/%i.cfg
-
-[Install]
-WantedBy=multi-user.target