summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Mulvey (mercury)2016-12-12 11:39:02 -0800
committerSam Mulvey (mercury)2016-12-12 11:39:02 -0800
commit3e737b87825f3cd0bd558e6e90452eed3dceb92c (patch)
tree38ae66c7faa76a8a87e2e5c3da8b4c12a8cf8c58
parentf557c307649c9a8ebdef483dfd1860086a7964f9 (diff)
downloadaur-3e737b87825f3cd0bd558e6e90452eed3dceb92c.tar.gz
updated to 1.3 via git repo with upstream changes using PKGBUILD from B3l3tte, just adding some deps
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
-rw-r--r--service10
3 files changed, 22 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1b3cdb48e38..fb088b328c06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = darkice
pkgdesc = Live audio streamer. Reads from audio interface, encodes, sends to streaming server.
- pkgver = 1.2
+ pkgver = 1.3
pkgrel = 1
- url = http://code.google.com/p/darkice/
+ url = http://www.darkice.org/
arch = i686
arch = x86_64
arch = armv6h
@@ -11,13 +11,15 @@ pkgbase = darkice
depends = lame
depends = libpulse
depends = faac
+ depends = libaacplus
depends = jack
depends = twolame
depends = opus
depends = libsamplerate
- source = http://darkice.googlecode.com/files/darkice-1.2.tar.gz
- source = service
- md5sums = de541ea95a73a50f2f5e700434c22329
+ depends = fftw
+ source = darkice::git+https://github.com/Ouack23/darkice.git#branch=master
+ source = https://aur.archlinux.org/cgit/aur.git/plain/service?h=darkice
+ md5sums = SKIP
md5sums = 1c1cde0a5c03a2190a48275c03016eb8
pkgname = darkice
diff --git a/PKGBUILD b/PKGBUILD
index 5cc4eb05eefa..6bf161811415 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,37 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Ganjolinux aka Basalari David <ganjolinux@gmail.com>
# Contributor: speps <speps at aur dot archlinux dot org>
+# Contributor: B3l3tte <ouack23 at yahoo.fr>
pkgname=darkice
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc="Live audio streamer. Reads from audio interface, encodes, sends to streaming server."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-url="http://code.google.com/p/darkice/"
+url="http://www.darkice.org/"
license=('GPL')
-depends=('lame' 'libpulse' 'faac' 'jack' 'twolame' 'opus' 'libsamplerate')
-source=("http://darkice.googlecode.com/files/${pkgname}-${pkgver}.tar.gz"
- 'service')
-md5sums=('de541ea95a73a50f2f5e700434c22329'
- '1c1cde0a5c03a2190a48275c03016eb8')
+depends=('lame' 'libpulse' 'faac' 'libaacplus' 'jack' 'twolame' 'opus' 'libsamplerate' 'fftw')
+source=('darkice::git+https://github.com/Ouack23/darkice.git#branch=master'
+'https://aur.archlinux.org/cgit/aur.git/plain/service?h=darkice')
+md5sums=('SKIP' '1c1cde0a5c03a2190a48275c03016eb8')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ mv "service?h=darkice" service
+
+ cd "$srcdir/$pkgname/$pkgname/trunk"
+
+ ./autogen.sh
./configure --prefix=/usr \
--sysconfdir=/etc \
--with-aacplus \
- --with-opus \
- --with-samplerate
+ --with-opus \
+ --with-samplerate
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname/$pkgname/trunk"
make DESTDIR="$pkgdir/" install
diff --git a/service b/service
deleted file mode 100644
index 5bb64d7d4062..000000000000
--- a/service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=DarkIce Live Stream %i
-After=network.target
-
-[Service]
-Type=simple
-ExecStart=/usr/bin/darkice -c /etc/darkice/%i.cfg
-
-[Install]
-WantedBy=multi-user.target