summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2024-06-19 12:06:49 +0000
committerChristopher Arndt2024-06-19 12:06:49 +0000
commit693c98bcdc7cc04ebe9c895ef75188856e06cfe6 (patch)
treeb8573fd19e62fbf2add358526984c4fea0456f56
parent56445f20eb3405788e9134d3cda1c9db00955018 (diff)
downloadaur-693c98bcdc7cc04ebe9c895ef75188856e06cfe6.tar.gz
feat: update package 'darkice' to 1.5-1 (#442)
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a05c1a04fba9..235395766bdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = darkice
pkgdesc = Reads live audio from backends, encodes it and streams it to a server
- pkgver = 1.4
- pkgrel = 3
+ pkgver = 1.5
+ pkgrel = 1
url = http://www.darkice.org/
arch = aarch64
arch = armv6h
arch = armv7h
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = alsa-lib
makedepends = faac
makedepends = flac
@@ -19,18 +19,21 @@ pkgbase = darkice
makedepends = twolame
makedepends = opus
depends = gcc-libs
- source = https://github.com/rafael2k/darkice/releases/download/v1.4/darkice-1.4.tar.gz
+ depends = glibc
+ source = darkice-1.5.tar.gz::https://github.com/rafael2k/darkice/archive/refs/tags/v1.5.tar.gz
source = darkice@.service
- sha256sums = e6a8ec2b447cf5b4ffaf9b62700502b6bdacebf00b476f4e9bf9f9fe1e3dd817
+ sha256sums = 2025b55f122ea4e9795b918cfeef84048b8c03eef513319eecce3bd141f4f0fc
sha256sums = 7c65f92c885ed7e141d3289fd8e108dc3d7c19d5c4b3f948e7ce3ad6c653cd12
pkgname = darkice
depends = gcc-libs
+ depends = glibc
depends = libmp3lame.so
depends = libogg.so
depends = libvorbis.so
depends = libvorbisenc.so
depends = libopus.so
+ depends = libFLAC.so
depends = libfaac.so
depends = libtwolame.so
depends = libasound.so
diff --git a/PKGBUILD b/PKGBUILD
index 7dd67095db33..e4f187157505 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,25 +7,24 @@
# Contributor: B3l3tte <ouack23 at yahoo.fr>
pkgname=darkice
-pkgver=1.4
-pkgrel=3
+pkgver=1.5
+pkgrel=1
pkgdesc='Reads live audio from backends, encodes it and streams it to a server'
arch=(aarch64 armv6h armv7h x86_64)
url='http://www.darkice.org/'
-license=(GPL3)
-depends=(gcc-libs)
+license=(GPL-3.0-or-later)
+depends=(gcc-libs glibc)
makedepends=(alsa-lib faac flac jack lame libpulse libsamplerate libvorbis twolame opus)
-source=("https://github.com/rafael2k/darkice/releases/download/v${pkgver}/$pkgname-$pkgver.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rafael2k/$pkgname/archive/refs/tags/v$pkgver.tar.gz"
'darkice@.service')
-sha256sums=('e6a8ec2b447cf5b4ffaf9b62700502b6bdacebf00b476f4e9bf9f9fe1e3dd817'
+sha256sums=('2025b55f122ea4e9795b918cfeef84048b8c03eef513319eecce3bd141f4f0fc'
'7c65f92c885ed7e141d3289fd8e108dc3d7c19d5c4b3f948e7ce3ad6c653cd12')
-
build() {
- cd $pkgname-$pkgver
+ cd $pkgname-$pkgver/darkice/trunk
export CXXFLAGS="$CXXFLAGS -std=c++11"
- ./configure \
+ ./autogen.sh \
--prefix=/usr \
--sysconfdir=/etc \
--with-alsa \
@@ -42,9 +41,9 @@ build() {
package() {
depends+=(libmp3lame.so libogg.so libvorbis.so libvorbisenc.so libopus.so
- libfaac.so libtwolame.so libasound.so libpulse-simple.so
+ libFLAC.so libfaac.so libtwolame.so libasound.so libpulse-simple.so
libpulse.so libjack.so libsamplerate.so)
- cd $pkgname-$pkgver
+ cd $pkgname-$pkgver/darkice/trunk
make DESTDIR="$pkgdir" install
# systemd service
install -Dm644 "$srcdir"/darkice@.service -t "$pkgdir"/usr/lib/systemd/user