summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-04-07 06:37:15 +0200
committerChristopher Arndt2020-04-09 15:21:39 +0200
commite8a7916a14f8a59b739bca98aa22afee5a8eb7c3 (patch)
treeff65cd0845c986d5fb08552a9c2024f6036234bc
parentc6740124b26cbce7d60963d67d2c5f001012af59 (diff)
downloadaur-e8a7916a14f8a59b739bca98aa22afee5a8eb7c3.tar.gz
Update to upstream version 1.4
* Change source to source distribution archive from https://github.com/rafael2k/darkice. * Remove call to './autogen.sh' in build function. * Explicitly configure all supported encoders. * Remove aacplus support (license status of libaacplus is problematic). * Fix pemission of systemd service file. * Use SHA256 source checksums instead of MD5.
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD51
3 files changed, 39 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98b30e2e36e9..721067a17b68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = darkice
pkgdesc = Live audio streamer. Reads from audio interface, encodes, sends to streaming server.
- pkgver = 1.3
- pkgrel = 2
+ pkgver = 1.4
+ pkgrel = 1
url = http://www.darkice.org/
arch = i686
arch = x86_64
@@ -11,16 +11,15 @@ pkgbase = darkice
depends = lame
depends = libpulse
depends = faac
- depends = libaacplus
depends = jack
depends = twolame
depends = opus
depends = libsamplerate
depends = fftw
- source = darkice::git+https://github.com/Ouack23/darkice.git#branch=master
+ source = https://github.com/rafael2k/darkice/releases/download/v1.4/darkice-1.4.tar.gz
source = service
- md5sums = SKIP
- md5sums = 1c1cde0a5c03a2190a48275c03016eb8
+ sha256sums = e6a8ec2b447cf5b4ffaf9b62700502b6bdacebf00b476f4e9bf9f9fe1e3dd817
+ sha256sums = c5d05b1c3c352eda9591064f041fcd502d3b0a4cfcc6319dc4ae9b6d71136e4b
pkgname = darkice
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ce1e2536a851
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+darkice-*.pkg.tar.xz
+darkice-*.pkg.tar.zst
+darkice-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index a3f9a7bc3481..a60a398b4d83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,40 +3,47 @@
# Contributor: Ganjolinux aka Basalari David <ganjolinux@gmail.com>
# Contributor: speps <speps at aur dot archlinux dot org>
# Contributor: B3l3tte <ouack23 at yahoo.fr>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot de>
pkgname=darkice
-pkgver=1.3
-pkgrel=2
+pkgver=1.4
+pkgrel=1
pkgdesc="Live audio streamer. Reads from audio interface, encodes, sends to streaming server."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://www.darkice.org/"
license=('GPL')
-depends=('lame' 'libpulse' 'faac' 'libaacplus' 'jack' 'twolame' 'opus' 'libsamplerate' 'fftw')
-source=('darkice::git+https://github.com/Ouack23/darkice.git#branch=master' 'service')
-md5sums=('SKIP' '1c1cde0a5c03a2190a48275c03016eb8')
+depends=('lame' 'libpulse' 'faac' 'jack' 'twolame' 'opus' 'libsamplerate' 'fftw')
+source=("https://github.com/rafael2k/darkice/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ 'service')
+sha256sums=('e6a8ec2b447cf5b4ffaf9b62700502b6bdacebf00b476f4e9bf9f9fe1e3dd817'
+ 'c5d05b1c3c352eda9591064f041fcd502d3b0a4cfcc6319dc4ae9b6d71136e4b')
-build() {
-
- cd "$srcdir/$pkgname/$pkgname/trunk"
-
- ./autogen.sh
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --with-aacplus \
- --with-opus \
- --with-samplerate
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-alsa \
+ --with-faac \
+ --with-jack \
+ --with-lame \
+ --with-opus \
+ --with-twolame \
+ --without-aacplus \
+ --with-pulseaudio \
+ --with-samplerate
make
}
package() {
- cd "$srcdir/$pkgname/$pkgname/trunk"
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
-
- # daemon
- install -Dm755 "$srcdir/service" "$pkgdir/usr/lib/systemd/system/darkice@.service"
-
- mkdir -p "$pkgdir/etc/darkice"
- mv "$pkgdir/etc/darkice.cfg" "$pkgdir/etc/darkice/darkice.cfg"
+ # systemd service
+ install -Dm644 "$srcdir/service" "$pkgdir/usr/lib/systemd/system/darkice@.service"
+ # configuration
+ install -dm755 "$pkgdir/etc/darkice"
+ mv "$pkgdir/etc/darkice.cfg" "$pkgdir/etc/darkice"
}