summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Mulvey (mothership)2015-07-07 07:26:26 -0700
committerSam Mulvey (mothership)2015-07-07 07:26:26 -0700
commitf557c307649c9a8ebdef483dfd1860086a7964f9 (patch)
tree478d822acde947c1be11c0f460242c4bff362e4b
downloadaur-f557c307649c9a8ebdef483dfd1860086a7964f9.tar.gz
initial import from aur3
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
-rw-r--r--service10
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1b3cdb48e38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = darkice
+ pkgdesc = Live audio streamer. Reads from audio interface, encodes, sends to streaming server.
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://code.google.com/p/darkice/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ depends = lame
+ depends = libpulse
+ depends = faac
+ depends = jack
+ depends = twolame
+ depends = opus
+ depends = libsamplerate
+ source = http://darkice.googlecode.com/files/darkice-1.2.tar.gz
+ source = service
+ md5sums = de541ea95a73a50f2f5e700434c22329
+ md5sums = 1c1cde0a5c03a2190a48275c03016eb8
+
+pkgname = darkice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cc4eb05eefa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Sam Mulvey <archlinux at sammulvey.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Ganjolinux aka Basalari David <ganjolinux@gmail.com>
+# Contributor: speps <speps at aur dot archlinux dot org>
+
+pkgname=darkice
+pkgver=1.2
+pkgrel=1
+pkgdesc="Live audio streamer. Reads from audio interface, encodes, sends to streaming server."
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="http://code.google.com/p/darkice/"
+license=('GPL')
+depends=('lame' 'libpulse' 'faac' 'jack' 'twolame' 'opus' 'libsamplerate')
+source=("http://darkice.googlecode.com/files/${pkgname}-${pkgver}.tar.gz"
+ 'service')
+md5sums=('de541ea95a73a50f2f5e700434c22329'
+ '1c1cde0a5c03a2190a48275c03016eb8')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-aacplus \
+ --with-opus \
+ --with-samplerate
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+
+ # daemon
+ install -Dm755 "$srcdir/service" "$pkgdir/usr/lib/systemd/system/darkice@.service"
+
+ mkdir -p "$pkgdir/etc/darkice"
+ mv "$pkgdir/etc/darkice.cfg" "$pkgdir/etc/darkice/darkice.cfg"
+}
diff --git a/service b/service
new file mode 100644
index 000000000000..5bb64d7d4062
--- /dev/null
+++ b/service
@@ -0,0 +1,10 @@
+[Unit]
+Description=DarkIce Live Stream %i
+After=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/darkice -c /etc/darkice/%i.cfg
+
+[Install]
+WantedBy=multi-user.target