summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2018-04-06 00:42:06 +0200
committerJosip Ponjavic2018-04-06 00:42:06 +0200
commit913e37ab8feafe4adb40b64eb6f02c769b3a291d (patch)
tree95fb1804a77baa0073e2cb0aa963e6f914f8752d
downloadaur-913e37ab8feafe4adb40b64eb6f02c769b3a291d.tar.gz
upgpkg: 1.4.r23.g37b765d-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fc4b5b9da3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = darkine-kde-git
+ pkgdesc = Theme based on Adapta KDE for Plasma 5 desktop
+ pkgver = 1.4.r23.g37b765d
+ pkgrel = 1
+ url = https://github.com/Rokin05/darkine-kde
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ optdepends = konsole: For the Konsole color scheme
+ optdepends = kvantum-qt5: For the Qt application style
+ optdepends = kwin: For the Aurorae theme
+ optdepends = papirus-icon-theme: For the Papirus-Adapta icon theme
+ optdepends = plasma-desktop: For the Plasma theme
+ optdepends = sddm: For the SDDM theme
+ provides = darkine-kde
+ conflicts = darkine-kde
+ options = !strip
+ source = darkine-kde::git+https://github.com/Rokin05/darkine-kde.git
+ sha256sums = SKIP
+
+pkgname = darkine-kde-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5049e9516b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+
+pkgname=darkine-kde-git
+pkgver=1.4.r23.g37b765d
+pkgrel=1
+pkgdesc="Theme based on Adapta KDE for Plasma 5 desktop"
+arch=('any')
+url="https://github.com/Rokin05/darkine-kde"
+license=('GPL3')
+optdepends=('konsole: For the Konsole color scheme'
+ 'kvantum-qt5: For the Qt application style'
+ 'kwin: For the Aurorae theme'
+ 'papirus-icon-theme: For the Papirus-Adapta icon theme'
+ 'plasma-desktop: For the Plasma theme'
+ 'sddm: For the SDDM theme')
+makedepends=('git' 'make')
+conflicts=("${pkgname%-*}")
+provides=("${pkgname%-*}")
+options=(!strip)
+source=("${pkgname%-*}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ ver="$(grep '#### Version' CHANGELOG.md | tail -1 | awk '{print $3}')"
+ printf '%s.r%s.g%s' "$ver" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ make -C "${pkgname%-*}" PREFIX=/usr DESTDIR="${pkgdir}/" install
+}