summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadow532015-06-11 14:00:37 -0700
committerShadow532015-06-11 14:00:37 -0700
commit9f0971ec7ab50f2d189c8c76e6e210f97d442f44 (patch)
tree96dd92fa90d5fb04ce902b84565735368b0b2933
downloadaur-9f0971ec7ab50f2d189c8c76e6e210f97d442f44.tar.gz
First commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD60
-rw-r--r--darkmod.desktop10
-rw-r--r--darkmod.install13
-rw-r--r--darkmod.pngbin0 -> 9951 bytes
5 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae6456d1fa26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by makepkg 4.2.1
+# Thu Jun 11 20:37:45 UTC 2015
+pkgbase = darkmod
+ pkgdesc = DOOM III standalone mod based on the Thief series by Looking Glass Studios
+ pkgver = 2.03
+ pkgrel = 2
+ url = http://www.thedarkmod.com/
+ install = darkmod.install
+ arch = i686
+ arch = x86_64
+ license = CCPL
+ makedepends = unzip
+ depends = lib32-glew
+ depends = lib32-libpng
+ depends = lib32-libjpeg-turbo
+ depends = lib32-libpng12
+ depends = lib32-curl
+ depends = lib32-libxxf86vm
+ depends = lib32-libpulse
+ depends = xterm
+ source = http://www.fidcal.com/darkuser/tdm_update_linux.zip
+ source = darkmod.desktop
+ source = darkmod.png
+ md5sums = c2e619ad6e5f39501d620b6f68e95233
+ md5sums = bc6537224b60c4ccfd04a51d80e340c1
+ md5sums = 5309e528ce22f28ecc0e9781e43379e0
+
+pkgname = darkmod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3177407d3617
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Michael Bryant (Shadow53)
+# Contributer: Benjamin Colard <benjamin at colard dot be>
+
+pkgname=darkmod
+pkgver=2.03
+pkgrel=2
+pkgdesc="DOOM III standalone mod based on the Thief series by Looking Glass Studios"
+arch=('i686' 'x86_64')
+url="http://www.thedarkmod.com/"
+license=('CCPL')
+
+makedepends=('unzip')
+[ "$CARCH" == i686 ] && depends=('glew' 'libpng' 'libjpeg-turbo' 'libpng12' 'curl' 'libxxf86vm' 'libpulse' 'xterm')
+
+[ "$CARCH" == x86_64 ] && depends=('lib32-glew' 'lib32-libpng' 'lib32-libjpeg-turbo' 'lib32-libpng12' 'lib32-curl' 'lib32-libxxf86vm' 'lib32-libpulse' 'xterm')
+
+install="$pkgname".install
+source=(http://www.fidcal.com/darkuser/tdm_update_linux.zip
+ "$pkgname".desktop
+ "$pkgname".png)
+
+md5sums=('c2e619ad6e5f39501d620b6f68e95233'
+ 'bc6537224b60c4ccfd04a51d80e340c1'
+ '5309e528ce22f28ecc0e9781e43379e0')
+
+build() {
+ cd "$srcdir"
+ if [ ! -d "$srcdir/darkmod" ]; then
+ mkdir $srcdir/darkmod
+ fi
+ cd darkmod
+ unzip -o $srcdir/tdm_update_linux.zip
+ chmod +x tdm_update.linux
+ xterm -e $srcdir/darkmod/tdm_update.linux
+ rm -f TheDarkMod.exe tdm_update.exe
+}
+
+package() {
+ cd "$srcdir"/darkmod
+
+ install -m755 -d "$pkgdir"/opt/darkmod/
+ install -m755 -d "$pkgdir"/usr/bin/
+ install -m755 -d "$pkgdir"/usr/share/{applications,icons,licenses/"$pkgname"}
+
+ cp -r * "$pkgdir"/opt/darkmod/
+ find "$pkgdir"/opt/darkmod/ -type d -exec chmod 755 {} \;
+ find "$pkgdir"/opt/darkmod/ -type f -exec chmod 644 {} \;
+ chmod 755 "$pkgdir"/opt/darkmod/thedarkmod.x86
+ install -m755 -d "$srcdir"/darkmod/ "$pkgdir"/usr/bin/
+
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ rm -f "$pkgdir"/opt/darkmod/LICENSE.txt
+
+ install -Dm644 "$srcdir"/"$pkgname".png "$pkgdir"/usr/share/icons/
+ install -Dm644 "$srcdir"/"$pkgname".desktop "$pkgdir"/usr/share/applications/
+
+ chgrp --recursive games $pkgdir/opt/darkmod
+ chmod g=rwx -R $pkgdir/opt/darkmod
+
+}
diff --git a/darkmod.desktop b/darkmod.desktop
new file mode 100644
index 000000000000..c9488f8a7a9f
--- /dev/null
+++ b/darkmod.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=DarkMod
+GenericName=Mod based on the Thief series
+Comment=
+Icon=darkmod
+Exec=darkmod
+Terminal=false
+Categories=Game;ActionGame;
diff --git a/darkmod.install b/darkmod.install
new file mode 100644
index 000000000000..2d7db858a4fe
--- /dev/null
+++ b/darkmod.install
@@ -0,0 +1,13 @@
+post_install() {
+if [ ! -f /usr/bin/darkmod ]; then
+ ln -s /opt/darkmod/thedarkmod.x86 /usr/bin/darkmod
+else
+ rm -f /usr/bin/darkmod
+ ln -s /opt/darkmod/thedarkmod.x86 /usr/bin/darkmod
+fi
+echo "User must be add to the 'games' group to be able to play"
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/darkmod.png b/darkmod.png
new file mode 100644
index 000000000000..5533cb723264
--- /dev/null
+++ b/darkmod.png
Binary files differ