summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2016-05-16 05:42:19 -0700
committerMike Swanson2016-05-16 05:42:19 -0700
commitb8adb5c0b809394ab1e39459f642664826ee31e9 (patch)
tree3104d3d1b81e8a636f4e6da4a7978dee86d688dd
parente83da735b47f8f53a995d5e4a280050c64ef1f61 (diff)
downloadaur-b8adb5c0b809394ab1e39459f642664826ee31e9.tar.gz
Use /usr/share/games/quake and don't strip debugging symbols
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD26
-rw-r--r--darkplaces.install15
3 files changed, 33 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d2c6f8fc804..999bc85dd92c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon May 16 12:39:16 UTC 2016
pkgbase = darkplaces
pkgdesc = An advanced Quake 1 game engine
pkgver = 20140513
- pkgrel = 1
+ pkgrel = 2
url = http://icculus.org/twilight/darkplaces/
install = darkplaces.install
arch = i686
@@ -17,6 +19,7 @@ pkgbase = darkplaces
depends = libxpm
depends = libxxf86vm
depends = sdl
+ noextract = darkplacesengine20140513.zip
source = http://icculus.org/twilight/darkplaces/files/darkplacesengine20140513.zip
source = darkplaces.desktop
sha256sums = 69e5a50991884196e403bd6aab4a33bba553a934a167be366672ab4e223b06c9
diff --git a/PKGBUILD b/PKGBUILD
index 494c80fa64a4..3085ab98a2eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=darkplaces
pkgver=20140513
-pkgrel=1
+pkgrel=2
pkgdesc="An advanced Quake 1 game engine"
arch=('i686' 'x86_64')
url="http://icculus.org/twilight/darkplaces/"
@@ -16,24 +16,30 @@ source=(http://icculus.org/twilight/$pkgname/files/darkplacesengine$pkgver.zip
$pkgname.desktop)
sha256sums=('69e5a50991884196e403bd6aab4a33bba553a934a167be366672ab4e223b06c9'
'476f513f85da873ce93c89f2078bf9c2ea244e3e13a19c6ab02e818ddf221c37')
+noextract=(darkplacesengine$pkgver.zip)
+
+prepare() {
+ cd "$srcdir"
+ bsdtar -xf darkplacesengine$pkgver.zip darkplacesenginesource$pkgver.zip
+ bsdtar -xf darkplacesenginesource$pkgver.zip
+ cd "$pkgname"
+
+ # Fix a couple options in the Makefile.
+ sed -i '1i DP_LINK_TO_LIBJPEG=1' makefile
+ sed -i '/(STRIP)/d' makefile.inc
+}
build() {
- # Extract the package
- cd $srcdir
- bsdtar -xf darkplacesenginesource$pkgver.zip || return 1
+ cd "$srcdir/$pkgname"
# Make sure Darkplaces is not compiled with -j > 1.
MAKEFLAGS="${MAKEFLAGS} -j1"
-
- # Compile
- cd $pkgname
- sed -i -e '1i DP_LINK_TO_LIBJPEG=1' makefile
- make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/quake release || return 1
+ make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/games/quake release
}
package() {
cd $srcdir/$pkgname
- install -d $pkgdir/usr/{bin,share/quake}
+ install -d $pkgdir/usr/bin
install -m755 darkplaces-{dedicated,glx,sdl} $pkgdir/usr/bin
for i in 16 24 32 48 64 72; do
diff --git a/darkplaces.install b/darkplaces.install
index 2150e2d21366..956032354e0f 100644
--- a/darkplaces.install
+++ b/darkplaces.install
@@ -1,4 +1,15 @@
post_install() {
- echo ">>> You need the Quake 1 data to play."
- echo ">>> Copy your \"id1\" directory to /usr/share/quake"
+ cat <<EOF
+You need the Quake 1 data files to play.
+Copy the "id1" directory to /usr/share/games/quake
+EOF
+}
+
+post_upgrade() {
+ if [ "$(vercmp "$1" 20140513-1)" -eq 1 ]; then
+ cat <<EOF
+The Quake data directory has changed to /usr/share/games/quake
+You may need to move or link your current data from /usr/share/quake
+EOF
+ fi
}