summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2012-12-27 16:33:10 -0800
committerMike Swanson2012-12-27 16:33:10 -0800
commitd846fa1cfe5031b48ecc7c25f15232be9b3d669c (patch)
treeea380bbb19004225ac4023b5081c31410cce7dc4
parentf09d2010916ebdd0ff0257f6b82e8ba7013fcad4 (diff)
downloadaur-d846fa1cfe5031b48ecc7c25f15232be9b3d669c.tar.gz
Update darkplaces to 20121222.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD44
2 files changed, 30 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fda70b7aae3d..c4153558c959 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = darkplaces
pkgdesc = An advanced Quake 1 game engine
- pkgver = 20110628
- pkgrel = 2
+ pkgver = 20121222
+ pkgrel = 1
url = http://icculus.org/twilight/darkplaces/
install = darkplaces.install
arch = i686
@@ -12,15 +12,15 @@ pkgbase = darkplaces
makedepends = xf86vidmodeproto
makedepends = xproto
depends = alsa-lib
- depends = libjpeg6
+ depends = hicolor-icon-theme
+ depends = libjpeg-turbo
depends = libxpm
depends = libxxf86vm
- depends = libxxf86dga
depends = sdl
- source = http://icculus.org/twilight/darkplaces/files/darkplacesengine20110628.zip
+ source = http://icculus.org/twilight/darkplaces/files/darkplacesengine20121222.zip
source = darkplaces.desktop
- md5sums = c42103732cedfcf385ee959db9db6cb4
- md5sums = 31dd47a4969ad5d9d0e1c59db1d0e1e2
+ sha256sums = 13f3a2e5703cc6de1006d071dbdfd44627ead21425df35a3a9eb525e4b8c439f
+ sha256sums = 476f513f85da873ce93c89f2078bf9c2ea244e3e13a19c6ab02e818ddf221c37
pkgname = darkplaces
diff --git a/PKGBUILD b/PKGBUILD
index c1d47e5d83d3..5e9092cc4612 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,40 +3,42 @@
# Contributor: Paul Bredbury <brebs@sent.com>
pkgname=darkplaces
-pkgver=20110628
-pkgrel=2
+pkgver=20121222
+pkgrel=1
pkgdesc="An advanced Quake 1 game engine"
arch=('i686' 'x86_64')
url="http://icculus.org/twilight/darkplaces/"
license=('GPL2')
-depends=('alsa-lib' 'libjpeg6' 'libxpm' 'libxxf86vm' 'libxxf86dga' 'sdl')
+depends=('alsa-lib' 'hicolor-icon-theme' 'libjpeg-turbo' 'libxpm' 'libxxf86vm' 'sdl')
makedepends=('xextproto' 'xf86dgaproto' 'xf86vidmodeproto' 'xproto')
install=$pkgname.install
source=(http://icculus.org/twilight/$pkgname/files/darkplacesengine$pkgver.zip
$pkgname.desktop)
-md5sums=('c42103732cedfcf385ee959db9db6cb4'
- '31dd47a4969ad5d9d0e1c59db1d0e1e2')
+sha256sums=('13f3a2e5703cc6de1006d071dbdfd44627ead21425df35a3a9eb525e4b8c439f'
+ '476f513f85da873ce93c89f2078bf9c2ea244e3e13a19c6ab02e818ddf221c37')
build() {
- # Extract the package
- cd $srcdir
- bsdtar -xf darkplacesenginesource$pkgver.zip || return 1
+ # Extract the package
+ cd $srcdir
+ bsdtar -xf darkplacesenginesource$pkgver.zip || return 1
- # Make sure Darkplaces is not compiled with -j > 1.
- MAKEFLAGS="${MAKEFLAGS} -j1"
+ # Make sure Darkplaces is not compiled with -j > 1.
+ MAKEFLAGS="${MAKEFLAGS} -j1"
- # Compile
- cd $pkgname
- sed -i -e '1i DP_LINK_TO_LIBJPEG=1' makefile
- make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/quake release || return 1
+ # Compile
+ cd $pkgname
+ sed -i -e '1i DP_LINK_TO_LIBJPEG=1' makefile
+ make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/quake release || return 1
+}
- # Install binary, icon and desktop files
- install -d $pkgdir/usr/{bin,share/quake}
- install -m 755 darkplaces-{dedicated,glx,sdl} $pkgdir/usr/bin/
+package() {
+ cd $srcdir/$pkgname
+ install -d $pkgdir/usr/{bin,share/quake}
+ install -m755 darkplaces-{dedicated,glx,sdl} $pkgdir/usr/bin
- for i in 16 24 32 48 64 72 ; do
- install -Dm 644 darkplaces${i}x$i.png $pkgdir/usr/share/icons/hicolor/${i}x$i/apps/darkplaces.png
- done
+ for i in 16 24 32 48 64 72; do
+ install -Dm644 darkplaces${i}x${i}.png $pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/darkplaces.png
+ done
- install -Dm 644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
}