summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxDShot2022-07-25 11:52:30 +0300
committerxDShot2022-07-25 11:52:30 +0300
commit1a604039e200ac7839b8fffa0eb8ba74b3e3684f (patch)
tree5ea78c86bcf389971c6c91c0336ba10a3f1d54b9
parent67d119f281f94b2613023abbaa6db83be968f97d (diff)
downloadaur-1a604039e200ac7839b8fffa0eb8ba74b3e3684f.tar.gz
0.8.5
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD18
2 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20ffda46b2e1..6a4435759872 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,32 @@
pkgbase = darkplaces-xonotic
- pkgdesc = An advanced Quake 1 game engine (Xonotic branch)
- pkgver = 0.8.2
+ pkgdesc = An advanced Quake 1 game engine (Xonotic fork)
+ pkgver = 0.8.5
pkgrel = 1
- url = http://icculus.org/twilight/darkplaces/
+ url = https://gitlab.com/xonotic/darkplaces
install = darkplaces-xonotic.install
arch = i686
arch = x86_64
license = GPL2
- makedepends = xextproto
- makedepends = xf86dgaproto
- makedepends = xf86vidmodeproto
- makedepends = xproto
+ makedepends = unzip
+ makedepends = mesa
+ makedepends = xorgproto
depends = alsa-lib
- depends = hicolor-icon-theme
+ depends = curl
depends = libjpeg-turbo
+ depends = libmodplug
+ depends = libvorbis
depends = libxpm
depends = libxxf86vm
depends = sdl2
+ depends = libpng>=1.4.0
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
provides = darkplaces
conflicts = darkplaces
- source = https://github.com/xonotic/darkplaces/archive/xonotic-v0.8.2.tar.gz
+ source = https://github.com/xonotic/darkplaces/archive/xonotic-v0.8.5.tar.gz
source = darkplaces-xonotic.desktop
- sha256sums = 203450aaf67f901e64442a64f5ea4e27d98a6e157618b8bd62311652e3f18a4a
+ sha256sums = c35dfc3e0c2500b6fe7f5cb651d9c9bb359f86ad9202f2877ed6d4eb761e3f18
sha256sums = 476f513f85da873ce93c89f2078bf9c2ea244e3e13a19c6ab02e818ddf221c37
pkgname = darkplaces-xonotic
-
diff --git a/PKGBUILD b/PKGBUILD
index 26716644f17e..51c26888e1c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,29 @@
# Contributor: Mikhail Burdin <xdshot9000@gmail.com>
pkgname=darkplaces-xonotic
-pkgver=0.8.2
+pkgver=0.8.5
pkgrel=1
-pkgdesc="An advanced Quake 1 game engine (Xonotic branch)"
+pkgdesc="An advanced Quake 1 game engine (Xonotic fork)"
arch=('i686' 'x86_64')
-url="http://icculus.org/twilight/darkplaces/"
+url="https://gitlab.com/xonotic/darkplaces"
license=('GPL2')
-depends=('alsa-lib' 'hicolor-icon-theme' 'libjpeg-turbo' 'libxpm' 'libxxf86vm' 'sdl2')
-makedepends=('xextproto' 'xf86dgaproto' 'xf86vidmodeproto' 'xproto')
+depends=('alsa-lib' 'curl' 'libjpeg-turbo' 'libmodplug' 'libvorbis' 'libxpm'
+ 'libxxf86vm' 'sdl2' 'libpng>=1.4.0' 'hicolor-icon-theme'
+ 'gtk-update-icon-cache' 'desktop-file-utils')
+makedepends=('unzip' 'mesa' 'xorgproto')
conflicts=('darkplaces')
provides=('darkplaces')
install=$pkgname.install
source=(https://github.com/xonotic/darkplaces/archive/xonotic-v$pkgver.tar.gz
$pkgname.desktop)
-sha256sums=('203450aaf67f901e64442a64f5ea4e27d98a6e157618b8bd62311652e3f18a4a'
+sha256sums=('c35dfc3e0c2500b6fe7f5cb651d9c9bb359f86ad9202f2877ed6d4eb761e3f18'
'476f513f85da873ce93c89f2078bf9c2ea244e3e13a19c6ab02e818ddf221c37')
build() {
cd "${srcdir}/${pkgname}-v${pkgver}"
# Compile
- make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/games/quake DP_LINK_TO_LIBJPEG=1 cl-release
- make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/games/quake DP_LINK_TO_LIBJPEG=1 sdl-release
- make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/games/quake DP_LINK_TO_LIBJPEG=1 sv-release
+ make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/games/quake DP_LINK_TO_LIBJPEG=1 release
}
package() {