summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Brummer2018-02-15 14:07:21 +0100
committerBenoit Brummer2018-02-15 14:07:21 +0100
commita56886e1f40a04692913cf8f9a57c89c14f56bb6 (patch)
tree27f70b969ae355a5732c2a42f0d7758a4f0a9efe
downloadaur-darktable-lua-scripts-git.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38970539d021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = darktable-lua-scripts-git
+ pkgdesc = Lua scripts extending darktable
+ pkgver = r407.54572de
+ pkgrel = 1
+ url = https://github.com/darktable-org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = darktable
+ optdepends = hugin: hugins support
+ optdepends = enblend-enfuse: enfuse support
+ source = git+https://github.com/darktable-org/lua-scripts.git
+ sha256sums = SKIP
+
+pkgname = darktable-lua-scripts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6af80358c3c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: trougnouf (Benoit Brummer) <trougnouf at gmail dot com>
+pkgname='darktable-lua-scripts-git'
+_name='lua-scripts'
+pkgver=r407.54572de
+pkgrel=1
+pkgdesc='Lua scripts extending darktable'
+url='https://github.com/darktable-org/'
+depends=('darktable')
+optdepends=( 'hugin: hugins support'
+ 'enblend-enfuse: enfuse support')
+makedepends=()
+license=('GPL3')
+arch=('i686' 'x86_64')
+source=(git+"${url}${_name}.git")
+sha256sums=('SKIP')
+
+# To enable one of the scripts you have to add a line like require "examples/hello_world" to your: ~/.config/darktable/luarc (Linux/Unix)
+
+pkgver() {
+ cd ${_name}
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/darktable"
+ cp -r "${srcdir}/${_name}" "${pkgdir}/usr/share/darktable/lua"
+}
+