summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Brink2019-07-22 18:20:10 -0700
committerJames Brink2019-07-22 18:20:10 -0700
commitd9a07f8bcdf3c4a526ad2d0988755b18afded029 (patch)
tree1c094c0707148358673402c90bb5e47c8437e3cc
parent4882e11591b49c5dc5681424f391048cf32e3f95 (diff)
downloadaur-d9a07f8bcdf3c4a526ad2d0988755b18afded029.tar.gz
Add provides section to each package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 5 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47c999ae4805..997fcf082400 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -240,6 +240,7 @@ pkgbase = darling
pkgname = darling
install = darling.install
depends = darling-mach-dkms
+ provides = darling
conflicts = darling-git
pkgname = darling-mach-dkms
@@ -248,5 +249,6 @@ pkgname = darling-mach-dkms
optdepends = linux-lts-headers: build modules against the LTS kernel
optdepends = linux-zen-headers: build modules against the ZEN kernel
optdepends = linux-grsec-headers: build modules against the GRSEC kernel
+ provides = darling-mach-dkms
conflicts = darling-mach-dkms-git
diff --git a/PKGBUILD b/PKGBUILD
index 24665ca1fb60..3524e63d4445 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: James Brink <brink.james@gmail.com>
+# Contributor: X0rg
_gitname=darling
pkgbase=$_gitname
@@ -264,6 +265,7 @@ package_darling() {
install=darling.install
depends=('darling-mach-dkms')
conflicts=('darling-git')
+ provides=('darling')
cd "$srcdir/$_gitname/build"
make DESTDIR="$pkgdir" install
@@ -275,6 +277,7 @@ package_darling() {
package_darling-mach-dkms() {
depends=('dkms')
conflicts=('darling-mach-dkms-git')
+ provides=('darling-mach-dkms')
optdepends=('linux-headers: build modules against the Arch kernel'
'linux-lts-headers: build modules against the LTS kernel'
'linux-zen-headers: build modules against the ZEN kernel'