summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-07-04 22:38:12 +0800
committerChih-Hsuan Yen2018-07-04 22:38:12 +0800
commit8a67a687d373eb0bf207b753934a863bd7c443f8 (patch)
tree214e87eceb7a6bf6d33d7160daecef82aa132885
parent6470636573e3dc464edfdfe00a8ae1a2b037ed4d (diff)
downloadaur-8a67a687d373eb0bf207b753934a863bd7c443f8.tar.gz
fix checksums
buildbot=build_packages
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
-rw-r--r--enoattr.patch14
-rw-r--r--issue51.patch16
5 files changed, 22 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b21e56aff2b7..53e3fea044b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = darling-dmg-git
pkgdesc = FUSE module for .dmg files (containing an HFS+ filesystem)
- pkgver = 1.0.4.r22.geca0aea
+ pkgver = 1.0.4.r26.g524bfa6
pkgrel = 1
epoch = 1
url = https://www.darlinghq.org
@@ -16,13 +16,13 @@ pkgbase = darling-dmg-git
depends = libxml2
depends = openssl
depends = zlib
- provides = darling-dmg=1.0.4.r22.geca0aea
+ provides = darling-dmg=1.0.4.r26.g524bfa6
conflicts = darling-git
conflicts = darling-dmg
source = git+https://github.com/darlinghq/darling-dmg
- source = issue51.patch
+ source = enoattr.patch
sha256sums = SKIP
- sha256sums = ef77322fc0e4792f0ba5ff3f1aa67ca2078a02e502777c2483816f55fc255277
+ sha256sums = c0d15ceffbf957d823dc69b8c5adbfc4ef8c9ddd500fe8e118bac51f4d8ad0f7
pkgname = darling-dmg-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index fee45fdf7351..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-/darling-dmg/
diff --git a/PKGBUILD b/PKGBUILD
index a717454fb891..bfa5c1cfff1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=darling-dmg
pkgname=$_pkgname-git
-pkgver=1.0.4.r22.geca0aea
+pkgver=1.0.4.r26.g524bfa6
pkgrel=1
epoch=1
pkgdesc="FUSE module for .dmg files (containing an HFS+ filesystem)"
@@ -14,9 +14,9 @@ depends=('bzip2' 'fuse' 'icu' 'libxml2' 'openssl' 'zlib')
# boost is used only in check() but the build step requires it to build a test executable
makedepends=('cmake' 'git' 'boost')
source=("git+https://github.com/darlinghq/darling-dmg"
- issue51.patch)
+ enoattr.patch)
sha256sums=('SKIP'
- 'ef77322fc0e4792f0ba5ff3f1aa67ca2078a02e502777c2483816f55fc255277')
+ 'c0d15ceffbf957d823dc69b8c5adbfc4ef8c9ddd500fe8e118bac51f4d8ad0f7')
conflicts=('darling-git' "$_pkgname")
provides=("$_pkgname=$pkgver")
@@ -30,8 +30,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
-
- patch -Np1 -i ../issue51.patch
+ patch -Np1 -i ../enoattr.patch
}
build() {
diff --git a/enoattr.patch b/enoattr.patch
new file mode 100644
index 000000000000..2fbad07131e3
--- /dev/null
+++ b/enoattr.patch
@@ -0,0 +1,14 @@
+diff --git a/src/main-fuse.cpp b/src/main-fuse.cpp
+index f6b28c7..059666f 100644
+--- a/src/main-fuse.cpp
++++ b/src/main-fuse.cpp
+@@ -18,6 +18,9 @@
+ #ifdef DARLING
+ # include "stat_xlate.h"
+ #endif
++#if __linux__
++# include <attr/attributes.h>
++#endif
+
+ std::shared_ptr<Reader> g_fileReader;
+ std::unique_ptr<HFSHighLevelVolume> g_volume;
diff --git a/issue51.patch b/issue51.patch
deleted file mode 100644
index e2040d9a8a38..000000000000
--- a/issue51.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/src/HFSBTreeNode.h b/src/HFSBTreeNode.h
-index 0a98378..029f60a 100644
---- a/src/HFSBTreeNode.h
-+++ b/src/HFSBTreeNode.h
-@@ -129,6 +129,11 @@ public:
- m_index++;
- return *this;
- }
-+ RecordIterator& operator--()
-+ {
-+ m_index--;
-+ return *this;
-+ }
-
- difference_type operator-(const RecordIterator& that)
- {