summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamir DAHAN2020-11-07 03:38:52 +0100
committerSamir DAHAN2020-11-07 03:38:52 +0100
commit7966e87f8cf0c0f11e36465c119298103cd59743 (patch)
treec5851ef56ef3a7dc8ecd812cbc2fa747fb509d07
downloadaur-7966e87f8cf0c0f11e36465c119298103cd59743.tar.gz
feat(dasel): first release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8e91e6b4518
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dasel
+ pkgdesc = Query and update data structures from the command line.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/TomWright/dasel
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = https://github.com/TomWright/dasel/archive/v1.2.0.tar.gz
+ sha256sums = b6bcf1045f976ecd95af5c8245c59644940b7f73bca0e84f3c228ae0d977346c
+
+pkgname = dasel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3039f52d4fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alkindi42
+
+pkgname=dasel
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Query and update data structures from the command line."
+arch=('x86_64')
+url="https://github.com/TomWright/dasel"
+license=('MIT')
+makedepends=('go' 'git')
+source=("https://github.com/TomWright/$pkgname/archive/v${pkgver}.tar.gz")
+sha256sums=('b6bcf1045f976ecd95af5c8245c59644940b7f73bca0e84f3c228ae0d977346c')
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -ldflags "-X main.BuildDate=$(date -u '+%Y-%m-%dT%I:%M:%S%p')" \
+ -o $pkgname ./cmd/dasel/main.go
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 dasel "$pkgdir/usr/bin/dasel"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}