summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2020-02-13 17:40:58 +1100
committerLuis Aranguren2020-02-13 17:40:58 +1100
commit4eef1b7e3829e6b86296556bd6039af4183472c1 (patch)
treed00137ab9c35b4f55ca78cb693b2b98a71d9ce0b
parentd94526f2d6483ee14509f6aee835a52a3ac59c1e (diff)
downloadaur-4eef1b7e3829e6b86296556bd6039af4183472c1.tar.gz
General cleanup, added codablock-bls-signatures to makedepends, added deque.patch
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
-rw-r--r--deque.patch58
3 files changed, 92 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd5187a66cd5..0fbbb337e45b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,22 @@
pkgbase = dash
pkgdesc = Dash peer-to-peer network based digital currency
pkgver = 0.14.0.5
- pkgrel = 1
- url = http://www.dashpay.io/
- arch = i686
+ pkgrel = 2
+ url = http://www.dash.org/
arch = x86_64
license = MIT
makedepends = boost
- makedepends = automoc4
- makedepends = qrencode
- makedepends = miniupnpc
- makedepends = protobuf
- makedepends = zeromq
+ makedepends = codablock-bls-signatures
depends = boost-libs
depends = libevent
- optdepends = zeromq: Optional, allows generating ZMQ notifications
optdepends = miniupnpc: Firewall-jumping support
- optdepends = db4.8: Wallet storage
+ optdepends = db4.8: Wallet storage and wallet portability
source = dash-daemon-0.14.0.5.tar.gz::https://github.com/dashpay/dash/archive/v0.14.0.5.tar.gz
source = dashd@.service
+ source = deque.patch
sha512sums = 48344e2fe43ca9d2e8621f59b5141243ca3d9da58da7701903ce65d8b56e41bb98cf31e8284835f2303182a934a4df5cc4e13438d346938851fda79d924cb388
sha512sums = b5c59efacbe85de0292590af12e35d8c001c2b71eebda9829754be48e61a70ad7e8ed99662ed4e8da53006eb72e1994c435813b35c16a9c566ddf455efe81b5b
+ sha512sums = bb85a882cf5646cef7eb50a4fd1c60fb50409fafc5ef18351a767fce927fd7dbe616b468f74d02d4ed267683de798e563b9cd7be9b1c7a5100113b2164b54825
pkgname = dash-daemon
pkgdesc = Dash peer-to-peer network based digital currency (daemon)
diff --git a/PKGBUILD b/PKGBUILD
index a4dd198c3ead..d6ea7b7dc69d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,33 @@
-# Maintainer: Marcin (CTRL) Wieczorek <marcin@marcin.co>
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+# Contributor: Marcin (CTRL) Wieczorek <marcin@marcin.co>
# Contributor: Nicolas Doualot <packages@slubman.info>
pkgname=('dash-daemon' 'dash-cli' 'dash-qt')
pkgbase=dash
pkgver=0.14.0.5
-pkgrel=1
-arch=('i686' 'x86_64')
-url="http://www.dashpay.io/"
+pkgrel=2
+arch=('x86_64')
+url="http://www.dash.org/"
depends=('boost-libs' 'libevent')
-makedepends=('boost' 'automoc4' 'qrencode' 'miniupnpc' 'protobuf' 'zeromq')
-optdepends=('zeromq: Optional, allows generating ZMQ notifications'
- 'miniupnpc: Firewall-jumping support'
- 'db4.8: Wallet storage')
+makedepends=('boost' 'codablock-bls-signatures')
+optdepends=('miniupnpc: Firewall-jumping support'
+ 'db4.8: Wallet storage and wallet portability')
pkgdesc="Dash peer-to-peer network based digital currency "
license=('MIT')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dashpay/dash/archive/v${pkgver}.tar.gz"
- "dashd@.service")
+ 'dashd@.service'
+ 'deque.patch')
sha512sums=('48344e2fe43ca9d2e8621f59b5141243ca3d9da58da7701903ce65d8b56e41bb98cf31e8284835f2303182a934a4df5cc4e13438d346938851fda79d924cb388'
- 'b5c59efacbe85de0292590af12e35d8c001c2b71eebda9829754be48e61a70ad7e8ed99662ed4e8da53006eb72e1994c435813b35c16a9c566ddf455efe81b5b')
+ 'b5c59efacbe85de0292590af12e35d8c001c2b71eebda9829754be48e61a70ad7e8ed99662ed4e8da53006eb72e1994c435813b35c16a9c566ddf455efe81b5b'
+ 'bb85a882cf5646cef7eb50a4fd1c60fb50409fafc5ef18351a767fce927fd7dbe616b468f74d02d4ed267683de798e563b9cd7be9b1c7a5100113b2164b54825')
+
+prepare () {
+ cd "$pkgbase-$pkgver"
+ #deque patch 2020-02-12
+ #inlcude deque.h library in httpserver.cpp found in https://github.com/dogecoin/dogecoin/pull/1626
+ #will delete when dash fixes/commits this.
+ patch --forward --strip=1 --input="../../deque.patch"
+}
build() {
cd "${srcdir}/${pkgbase}-${pkgver}"
@@ -30,12 +40,11 @@ package_dash-daemon() {
pkgdesc+="(daemon)"
cd "${srcdir}/${pkgbase}-${pkgver}"
- install -Dm644 "${srcdir}/dashd@.service" "${pkgdir}/usr/lib/systemd/system/dash@.service"
- install -Dm755 "src/dashd" "${pkgdir}/usr/bin/dashd"
+ install -Dm644 "${srcdir}/dashd@.service" "${pkgdir}/usr/lib/systemd/system/dashd@.service"
+ install -Dm755 "src/dashd" "${pkgdir}/usr/bin/dashd"
install -Dm644 "contrib/debian/examples/dash.conf" "${pkgdir}/usr/share/doc/${pkgname}/examples/dash.conf"
- install -Dm644 "contrib/debian/manpages/dashd.1" "${pkgdir}/usr/share/man/man1/dashd.1"
- install -Dm644 "contrib/debian/manpages/dash.conf.5" "${pkgdir}/usr/share/man/man5/dash.conf.5"
- install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 "doc/man/dashd.1" "${pkgdir}/usr/share/man/man1/dashd.1"
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
package_dash-cli() {
@@ -44,7 +53,7 @@ package_dash-cli() {
cd "${srcdir}/${pkgbase}-${pkgver}"
install -Dm755 "src/dash-cli" "${pkgdir}/usr/bin/dash-cli"
install -Dm755 "src/dash-tx" "${pkgdir}/usr/bin/dash-tx"
- install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
package_dash-qt() {
@@ -55,8 +64,8 @@ package_dash-qt() {
pkgdesc+="(Qt)"
cd "${srcdir}/${pkgbase}-${pkgver}"
- install -Dm755 "src/qt/dash-qt" "${pkgdir}/usr/bin/dash-qt"
+ install -Dm755 "src/qt/dash-qt" "${pkgdir}/usr/bin/dash-qt"
install -Dm644 "contrib/debian/dash-qt.desktop" "${pkgdir}/usr/share/applications/dash.desktop"
- install -Dm644 "share/pixmaps/dash128.png" "${pkgdir}/usr/share/pixmaps/dash128.png"
- install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 "share/pixmaps/dash128.png" "${pkgdir}/usr/share/pixmaps/dash128.png"
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
diff --git a/deque.patch b/deque.patch
new file mode 100644
index 000000000000..8649cecfbe1d
--- /dev/null
+++ b/deque.patch
@@ -0,0 +1,58 @@
+From d53a3bebee798e54a83fa49e8abd7e0e3f719e03 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Fri, 24 Jan 2020 20:16:27 +0000
+Subject: [PATCH] httpserver: include deque
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+It seems gcc 9.2.0 requires deque to be included:
+
+ x86_64-pc-linux-gnu-g++ -std=c++11 -DHAVE_CONFIG_H -I. -I../src/config -I. -I./obj -I/usr/include/db5.1/ -pthread -I/usr/include -I./leveldb/include -I./leveldb/helpers/memenv -I./secp256k1/include -pthread -I/usr/include/db5.1 -DHAVE_BUILD_INFO -D__STDC_FORMAT_MACROS -march=native -O2 -pipe -fomit-frame-pointer -c -o libdogecoin_server_a-httpserver.o `test -f 'httpserver.cpp' || echo './'`httpserver.cpp
+ httpserver.cpp:71:10: error: ‘deque’ in namespace ‘std’ does not name a template type
+ 71 | std::deque<std::unique_ptr<WorkItem>> queue;
+ | ^~~~~
+ httpserver.cpp:30:1: note: ‘std::deque’ is defined in header ‘<deque>’; did you forget to ‘#include <deque>’?
+ 29 | #include <event2/keyvalq_struct.h>
+ +++ |+#include <deque>
+ 30 |
+ httpserver.cpp: In member function ‘bool WorkQueue<WorkItem>::Enqueue(WorkItem*)’:
+ httpserver.cpp:110:13: error: ‘queue’ was not declared in this scope; did you mean ‘Enqueue’?
+ 110 | if (queue.size() >= maxDepth) {
+ | ^~~~~
+ | Enqueue
+ httpserver.cpp:113:9: error: ‘queue’ was not declared in this scope; did you mean ‘Enqueue’?
+ 113 | queue.emplace_back(std::unique_ptr<WorkItem>(item));
+ | ^~~~~
+ | Enqueue
+ httpserver.cpp: In member function ‘void WorkQueue<WorkItem>::Run()’:
+ httpserver.cpp:125:35: error: ‘queue’ was not declared in this scope; did you mean ‘Enqueue’?
+ 125 | while (running && queue.empty())
+ | ^~~~~
+ | Enqueue
+ httpserver.cpp:129:31: error: ‘queue’ was not declared in this scope; did you mean ‘Enqueue’?
+ 129 | i = std::move(queue.front());
+ | ^~~~~
+ | Enqueue
+ httpserver.cpp: In member function ‘size_t WorkQueue<WorkItem>::Depth()’:
+ httpserver.cpp:154:16: error: ‘queue’ was not declared in this scope; did you mean ‘Enqueue’?
+ 154 | return queue.size();
+ | ^~~~~
+ | Enqueue
+---
+ src/httpserver.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/httpserver.cpp b/src/httpserver.cpp
+index dba9527305..5c08e676df 100644
+--- a/src/httpserver.cpp
++++ b/src/httpserver.cpp
+@@ -19,6 +19,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <signal.h>
++#include <deque>
+ #include <future>
+
+ #include <event2/event.h>
+