summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-03 14:03:40 +0800
committerChocobo12017-08-03 14:30:52 +0800
commit75462a562c967b6f76cbf05f56f260c3b0a0d0a4 (patch)
tree4f0355473f7f13ccb91ac26eb51dfba6896bea1d
downloadaur-75462a562c967b6f76cbf05f56f260c3b0a0d0a4.tar.gz
newpkg: dash-git 0.5.9.1.r0.gafe0e01-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--dash.install11
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e85bccf9bd4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dash-git
+ pkgdesc = A POSIX compliant shell that aims to be as small as possible
+ pkgver = 0.5.9.1.r0.gafe0e01
+ pkgrel = 1
+ url = http://gondor.apana.org.au/~herbert/dash/
+ install = dash.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = glibc
+ provides = dash
+ conflicts = dash
+ source = git+https://git.kernel.org/pub/scm/utils/dash/dash.git
+ sha256sums = SKIP
+
+pkgname = dash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2df5485eb2d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=dash-git
+pkgver=0.5.9.1.r0.gafe0e01
+pkgrel=1
+pkgdesc="A POSIX compliant shell that aims to be as small as possible"
+arch=('i686' 'x86_64')
+url="http://gondor.apana.org.au/~herbert/dash/"
+license=('BSD')
+depends=('glibc')
+makedepends=('git')
+provides=('dash')
+conflicts=('dash')
+install=dash.install
+source=("git+https://git.kernel.org/pub/scm/utils/dash/dash.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "dash"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "dash"
+
+ ./autogen.sh
+ ./configure --prefix="/usr" --enable-fnmatch --with-libedit
+
+ make
+}
+
+package() {
+ cd "dash"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/dash/COPYING"
+}
diff --git a/dash.install b/dash.install
new file mode 100644
index 000000000000..6b04cba300c0
--- /dev/null
+++ b/dash.install
@@ -0,0 +1,11 @@
+post_install() {
+ grep -q '/bin/dash' etc/shells || echo '/bin/dash' >> etc/shells
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ sed -i '/^\/bin\/dash/d' etc/shells
+}