summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Staal2017-08-06 18:17:05 +0200
committerJens Staal2017-08-06 18:17:05 +0200
commit88eb350dcd3d7f2c58f4914d01939f13993c5b74 (patch)
tree0278dd0c779be177fbb3b3e53de80716c03c0373
parentb093ab5050814291f0d61f9755d1b4adf0ec20c1 (diff)
downloadaur-88eb350dcd3d7f2c58f4914d01939f13993c5b74.tar.gz
update dash and make sure that make uses CC and CFLAGS
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71dc97a2d2ba..a452e6b5bea9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=dash-static-musl
_pkgbase=dash
-pkgver=0.5.8
+pkgver=0.5.9.1
pkgrel=1
pkgdesc="A POSIX compliant shell that aims to be as small as possible, statically linked to musl libc"
arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ conflicts=("$_pkgbase")
makedepends=('musl') #we are static
install=dash.install
source=("http://gondor.apana.org.au/~herbert/dash/files/${_pkgbase}-${pkgver}.tar.gz")
-sha1sums=('cd058935bba545427caa375337afe8a6309477d2')
+sha1sums=('7b9cb47fc2a007c26fedc99d22a7fc1dc2f5f914')
build() {
cd "${srcdir}/${_pkgbase}-${pkgver}"
@@ -28,7 +28,7 @@ build() {
--exec-prefix="" \
--with-libedit
- make
+ make CC=$CC CFLAGS=$CFLAGS
}
package() {