summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2020-10-12 16:38:19 +1100
committerLuis Aranguren2020-10-12 16:38:19 +1100
commit5262de0aaf54f01a03ebe13bdc9e186df4be5da9 (patch)
treecb5238c84c6dd850d7691c1cf5870650402a4fe4
parent608f8addded33eafe7dba859002bc36534a6dedc (diff)
downloadaur-5262de0aaf54f01a03ebe13bdc9e186df4be5da9.tar.gz
0.16.0.1 qpainterpath patch, fixed namcap unique download name error
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13ea612ed399..50a7ad6425e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dashcore
pkgdesc = Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy-centric digital currency. (Includes the qt-client, the headless daemon and the command-line tool.)
- pkgver = 0.15.0.0
- pkgrel = 3
+ pkgver = 0.16.0.1
+ pkgrel = 1
url = https://www.dash.org/
arch = x86_64
license = MIT
@@ -35,13 +35,15 @@ pkgbase = dashcore
source = dash256.png
source = dash-qt.desktop
source = deque.patch
+ source = qpainterpath.patch::https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690.patch
source = https://github.com/dashpay/dash/blob/master/COPYING
- source = https://github.com/dashpay/dash/archive/v0.15.0.0.tar.gz
+ source = dash-v0.16.0.1.tar.gz::https://github.com/dashpay/dash/archive/v0.16.0.1.tar.gz
sha256sums = d719e01df4b47f4d6f0d4d6eac50d402bebb4127d0b6d64764fe2a42e903819b
sha256sums = 41f83cb53ecf33688d899f83e09bd52f9aa8e6d7b9b0f30810f192988b26079a
sha256sums = ded0b32ec96d8cbe996557d57c1c31583d30567377d3e9a0c3168f0aec3c817e
+ sha256sums = 475b6c0e7bc8d797020bdfc048a6b66e0513482fd469d6da2a599d3811f81f52
sha256sums = b5290c16b194d488265f3af37a7ab74cb9fecea2de97b910670cefa4e0909853
- sha256sums = 5b9fb5a3d3d619cf5ed9f6459acef9a028b355c29fde0d8eb2459c8f61ea01e9
+ sha256sums = 5bcd797990404d8446a801ebc3fe6fbdd038589c806c9036db66813df4366a76
pkgname = dashcore
diff --git a/PKGBUILD b/PKGBUILD
index 870e18bf7f79..04bdf3faa157 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname='dashcore'
_pkgname='dash'
-pkgver=0.15.0.0
-pkgrel=3
+pkgver=0.16.0.1
+pkgrel=1
pkgdesc="Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy-centric digital currency. (Includes the qt-client, the headless daemon and the command-line tool.)"
arch=('x86_64')
url="https://www.dash.org/"
@@ -17,20 +17,27 @@ conflicts=('dashcore-git' 'dashcore-bin' 'dash-cli' 'dash-qt' 'dash-daemon')
source=('dash256.png'
'dash-qt.desktop'
'deque.patch'
+ 'qpainterpath.patch::https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690.patch'
'https://github.com/dashpay/dash/blob/master/COPYING'
- "https://github.com/dashpay/dash/archive/v${pkgver}.tar.gz")
+ "${_pkgname}-v${pkgver}.tar.gz::https://github.com/dashpay/dash/archive/v${pkgver}.tar.gz")
sha256sums=('d719e01df4b47f4d6f0d4d6eac50d402bebb4127d0b6d64764fe2a42e903819b'
'41f83cb53ecf33688d899f83e09bd52f9aa8e6d7b9b0f30810f192988b26079a'
'ded0b32ec96d8cbe996557d57c1c31583d30567377d3e9a0c3168f0aec3c817e'
+ '475b6c0e7bc8d797020bdfc048a6b66e0513482fd469d6da2a599d3811f81f52'
'b5290c16b194d488265f3af37a7ab74cb9fecea2de97b910670cefa4e0909853'
- '5b9fb5a3d3d619cf5ed9f6459acef9a028b355c29fde0d8eb2459c8f61ea01e9')
+ '5bcd797990404d8446a801ebc3fe6fbdd038589c806c9036db66813df4366a76')
prepare () {
cd "$_pkgname-$pkgver"
- #deque patch 2020-02-12
- #inlcude deque.h library in httpserver.cpp found in https://github.com/dogecoin/dogecoin/pull/1626
+ #deque patch 2020-02-12 == http: add missing header bootlegged by boost < 1.72
+ #inlcude deque library in src/httpserver.cpp found in https://github.com/bitcoin/bitcoin/commit/a5929130223973636f3fd25fbfaf2953f2ec96a9 and #inlcude deque.h library in httpserver.cpp found in https://github.com/dogecoin/dogecoin/pull/1626
#will delete when dash fixes/commits this.
patch --forward --strip=1 --input="../../deque.patch"
+
+ #QPainterPath 2020-10-12 == Add missing QPainterPath include
+ #include QPainterPath library in src/qt/trafficgraphwidget.cpp found in https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690
+ #will delete when dash fixes/commits this. This happens because dash is compiling against older versions of qt5-base
+ patch --forward --strip=1 --input="../../qpainterpath.patch"
}
build() {